366cb45d9a
== ChangeLog v1.2.3 == 14 files changed, 183 insertions(+), 26 deletions(-) This patch updates us to git 2.25.1, augments our tests, adds support for lzip and zstd, and fixes a crash in when following logs. == ChangeLog v1.2.2 == 38 files changed, 264 insertions(+), 153 deletions(-) In terms of features, this release adds support for per-repository overrides of the enable-blame command, since git-blame can be expensive on huge repos. == ChangeLog v1.2.1 == 6 files changed, 465 insertions(+), 39 deletions(-) Notable Changes: * The authentication filters have been revamped, and a new one using file-based access lists has been added. * A bug fix for the cached rc file for the snapshot-prefix. * A fix for a critical directory traversal vulnerability, when `enable-http-clone=1` is not turned off, discovered by Jann Horn. This is pretty nasty and all users must update immediately. == ChangeLog v1.2 == 41 files changed, 1000 insertions(+), 497 deletions(-) Notable Changes: * Update to git 2.18. * Proper age sorting of repositories. * Print symlink content properly. * Numerous fixes to our cache system, addressing issues experienced on high- volume sites like kernel.org. * A new view for git-blame, showing the latest commit for each line of a given file. * Annotated tags are now printed in a slightly darker color. * The prefix for snapshots can now be controlled from the configuration file via repo.snapshot-prefix=, rather than only using the repo's basename. This is useful for serving, say, linux-4.17.7.tar.gz from a repository called linux-stable.git. * The snapshot tarball compression types now control which archives are allowed to be served, instead of merely controlling what was shown as a link on the webpage. This allows sitemasters to keep their cache size under control and also prohibit the use of expensive compression routines. * Signatures can now be added for snapshot tarballs through the use of git notes. Details are found in the cgitrc(5) man page: https://git.zx2c4.com/cgit/tree/cgitrc.5.txt?id=22583c4992852fff08559c35fde7bf6f673d1644#n770 * The extra-head-content= option was added for appending additional meta-tags to the <head> section, such as those required for the `go get` utility. * Numerous important bug fixes, crash fixes, memory leak fixes, and compiler fixes.
26 lines
758 B
Text
26 lines
758 B
Text
$NetBSD: patch-git-Makefile,v 1.3 2020/03/31 13:59:33 roy Exp $
|
|
|
|
Don't put HOME into binaries.
|
|
|
|
--- git/Makefile.orig 2020-02-17 04:47:35.000000000 +0000
|
|
+++ git/Makefile 2020-03-31 13:41:57.076648624 +0000
|
|
@@ -522,7 +522,7 @@
|
|
# perllibdir
|
|
# This can help installing the suite in a relocatable way.
|
|
|
|
-prefix = $(HOME)
|
|
+prefix = $(PREFIX)
|
|
bindir = $(prefix)/bin
|
|
mandir = $(prefix)/share/man
|
|
infodir = $(prefix)/share/info
|
|
@@ -1174,8 +1174,8 @@
|
|
# Set CFLAGS, LDFLAGS and other *FLAGS variables. These might be
|
|
# tweaked by config.* below as well as the command-line, both of
|
|
# which'll override these defaults.
|
|
-CFLAGS = -g -O2 -Wall
|
|
-LDFLAGS =
|
|
+# CFLAGS = -g -O2 -Wall
|
|
+# LDFLAGS =
|
|
CC_LD_DYNPATH = -Wl,-rpath,
|
|
BASIC_CFLAGS = -I.
|
|
BASIC_LDFLAGS =
|