pkgsrc/graphics/glut/patches/patch-ae
jschauma 87938dc3b7 Finally update Mesa and friends after the distfile changed on the website
without a version bump.  Changes made, according to the website, for
libtool/autofoo fixes.

Some changes from Ron Roskens:
glut depends upon graphics/glu (otherwise its linked against X11R6 libs)

MesaDemos:
 rather than using the pre-built distribution makefiles,
 use the automake/configure built makefiles which have
 the build dependencies all setup.

This closes PR pkg/23476.
2003-11-18 16:10:55 +00:00

17 lines
647 B
Text

$NetBSD: patch-ae,v 1.1 2003/11/18 16:10:56 jschauma Exp $
--- src/GGI/Makefile.am.orig 2003-11-13 21:47:55.000000000 -0500
+++ src/GGI/Makefile.am 2003-11-13 21:48:04.000000000 -0500
@@ -7,10 +7,10 @@
ggimesaconfdatadir = ${sysconfdir}/ggi
ggimesaconfdata_DATA = ggimesa.conf
-INCLUDES += -I$(top_srcdir)/include -I$(top_srcdir)/src/GGI/include \
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/src/GGI/include \
-I$(top_srcdir)/src $(GGI_CFLAGS)
-DEFS += -DGGIMESACONFFILE=\"$(ggimesaconfdatadir)/ggimesa.conf\"
+DEFS = -DGGIMESACONFFILE=\"$(ggimesaconfdatadir)/ggimesa.conf\"
if HAVE_GGI
# Build a libtool convenience library.