f249fe66dc
* Restore html5 audio playback under NetBSD Changelog: New Significant new customization mode makes it easy to personalize your Web experience to access the features you use the most (learn more) New A new, easy to access menu sits in the right hand corner of Firefox and includes popular browser controls New Sleek new tabs provide an overall smoother look and fade into the background when not active New An interactive onboarding tour to guide users through the new Firefox changes New The ability to set up Firefox Sync by creating a Firefox account (learn more) New Gamepad API finalized and enabled (learn more) New HTTPS used for Yahoo Searches performed in en-US locale New Malay [ma] locale added Changed Clicking on a W3C Web Notification will switch to the originating tab Developer 'box-sizing' (dropping the -moz- prefix) implemented (learn more) Developer Console object available in Web Workers (learn more) Developer Promises enabled by default (learn more) Developer SharedWorker enabled by default Developer <input type="number"> implemented and enabled Developer <input type="color"> implemented and enabled Developer Enabled ECMAScript Internationalization API Developer Add-on bar has been removed, content moved to navigation bar Developer Implemented URLSearchParams from the URL specification (see MDN for details ) Fixed Various security fixes Fixed in Firefox 29 MFSA 2014-47 Debugger can bypass XrayWrappers with JavaScript MFSA 2014-46 Use-after-free in nsHostResolve MFSA 2014-45 Incorrect IDNA domain name matching for wildcard certificates MFSA 2014-44 Use-after-free in imgLoader while resizing images MFSA 2014-43 Cross-site scripting (XSS) using history navigations MFSA 2014-42 Privilege escalation through Web Notification API MFSA 2014-41 Out-of-bounds write in Cairo MFSA 2014-40 Firefox for Android addressbar suppression MFSA 2014-39 Use-after-free in the Text Track Manager for HTML video MFSA 2014-38 Buffer overflow when using non-XBL object as XBL MFSA 2014-37 Out of bounds read while decoding JPG images MFSA 2014-36 Web Audio memory corruption issues MFSA 2014-35 Privilege escalation through Mozilla Maintenance Service Installer MFSA 2014-34 Miscellaneous memory safety hazards (rv:29.0 / rv:24.5)
175 lines
6.8 KiB
Text
175 lines
6.8 KiB
Text
$NetBSD: patch-as,v 1.10 2014/04/30 15:07:18 ryoon Exp $
|
|
|
|
Treat DragonFly like FreeBSD.
|
|
|
|
--- js/src/configure.in.orig 2014-04-18 02:03:06.000000000 +0000
|
|
+++ js/src/configure.in
|
|
@@ -2165,116 +2165,13 @@ AC_LANG_CPLUSPLUS
|
|
|
|
MOZ_CXX11
|
|
|
|
-dnl Check for .hidden assembler directive and visibility attribute.
|
|
-dnl Borrowed from glibc configure.in
|
|
+dnl Setup default hidden visibility and wrapped system headers.
|
|
dnl ===============================================================
|
|
if test "$GNU_CC"; then
|
|
- AC_CACHE_CHECK(for visibility(hidden) attribute,
|
|
- ac_cv_visibility_hidden,
|
|
- [cat > conftest.c <<EOF
|
|
- int foo __attribute__ ((visibility ("hidden"))) = 1;
|
|
-EOF
|
|
- ac_cv_visibility_hidden=no
|
|
- if ${CC-cc} -Werror -S conftest.c -o conftest.s >/dev/null 2>&1; then
|
|
- if egrep '\.(hidden|private_extern).*foo' conftest.s >/dev/null; then
|
|
- ac_cv_visibility_hidden=yes
|
|
- fi
|
|
- fi
|
|
- rm -f conftest.[cs]
|
|
- ])
|
|
- if test "$ac_cv_visibility_hidden" = "yes"; then
|
|
- AC_DEFINE(HAVE_VISIBILITY_HIDDEN_ATTRIBUTE)
|
|
-
|
|
- AC_CACHE_CHECK(for visibility(default) attribute,
|
|
- ac_cv_visibility_default,
|
|
- [cat > conftest.c <<EOF
|
|
- int foo __attribute__ ((visibility ("default"))) = 1;
|
|
-EOF
|
|
- ac_cv_visibility_default=no
|
|
- if ${CC-cc} -fvisibility=hidden -Werror -S conftest.c -o conftest.s >/dev/null 2>&1; then
|
|
- if ! egrep '\.(hidden|private_extern).*foo' conftest.s >/dev/null; then
|
|
- ac_cv_visibility_default=yes
|
|
- fi
|
|
- fi
|
|
- rm -f conftest.[cs]
|
|
- ])
|
|
- if test "$ac_cv_visibility_default" = "yes"; then
|
|
- AC_DEFINE(HAVE_VISIBILITY_ATTRIBUTE)
|
|
-
|
|
- AC_CACHE_CHECK(for visibility pragma support,
|
|
- ac_cv_visibility_pragma,
|
|
- [cat > conftest.c <<EOF
|
|
-#pragma GCC visibility push(hidden)
|
|
- int foo_hidden = 1;
|
|
-#pragma GCC visibility push(default)
|
|
- int foo_default = 1;
|
|
-EOF
|
|
- ac_cv_visibility_pragma=no
|
|
- if ${CC-cc} -Werror -S conftest.c -o conftest.s >/dev/null 2>&1; then
|
|
- if egrep '\.(hidden|private_extern).*foo_hidden' conftest.s >/dev/null; then
|
|
- if ! egrep '\.(hidden|private_extern).*foo_default' conftest.s > /dev/null; then
|
|
- ac_cv_visibility_pragma=yes
|
|
- fi
|
|
- fi
|
|
- fi
|
|
- rm -f conftest.[cs]
|
|
- ])
|
|
- if test "$ac_cv_visibility_pragma" = "yes"; then
|
|
- AC_CACHE_CHECK(For gcc visibility bug with class-level attributes (GCC bug 26905),
|
|
- ac_cv_have_visibility_class_bug,
|
|
- [cat > conftest.c <<EOF
|
|
-#pragma GCC visibility push(hidden)
|
|
-struct __attribute__ ((visibility ("default"))) TestStruct {
|
|
- static void Init();
|
|
-};
|
|
-__attribute__ ((visibility ("default"))) void TestFunc() {
|
|
- TestStruct::Init();
|
|
-}
|
|
-EOF
|
|
- ac_cv_have_visibility_class_bug=no
|
|
- if ! ${CXX-g++} ${CXXFLAGS} ${DSO_PIC_CFLAGS} ${DSO_LDOPTS} -S -o conftest.S conftest.c > /dev/null 2>&1 ; then
|
|
- ac_cv_have_visibility_class_bug=yes
|
|
- else
|
|
- if test `egrep -c '@PLT|\\$stub' conftest.S` = 0; then
|
|
- ac_cv_have_visibility_class_bug=yes
|
|
- fi
|
|
- fi
|
|
- rm -rf conftest.{c,S}
|
|
- ])
|
|
-
|
|
- AC_CACHE_CHECK(For x86_64 gcc visibility bug with builtins (GCC bug 20297),
|
|
- ac_cv_have_visibility_builtin_bug,
|
|
- [cat > conftest.c <<EOF
|
|
-#pragma GCC visibility push(hidden)
|
|
-#pragma GCC visibility push(default)
|
|
-#include <string.h>
|
|
-#pragma GCC visibility pop
|
|
-
|
|
-__attribute__ ((visibility ("default"))) void Func() {
|
|
- char c[[100]];
|
|
- memset(c, 0, sizeof(c));
|
|
-}
|
|
-EOF
|
|
- ac_cv_have_visibility_builtin_bug=no
|
|
- if ! ${CC-cc} ${CFLAGS} ${DSO_PIC_CFLAGS} ${DSO_LDOPTS} -O2 -S -o conftest.S conftest.c > /dev/null 2>&1 ; then
|
|
- ac_cv_have_visibility_builtin_bug=yes
|
|
- else
|
|
- if test `grep -c "@PLT" conftest.S` = 0; then
|
|
- ac_cv_visibility_builtin_bug=yes
|
|
- fi
|
|
- fi
|
|
- rm -f conftest.{c,S}
|
|
- ])
|
|
- if test "$ac_cv_have_visibility_builtin_bug" = "no" -a \
|
|
- "$ac_cv_have_visibility_class_bug" = "no"; then
|
|
- VISIBILITY_FLAGS='-I$(DIST)/system_wrappers -include $(topsrcdir)/config/gcc_hidden.h'
|
|
- WRAP_SYSTEM_INCLUDES=1
|
|
- else
|
|
- VISIBILITY_FLAGS='-fvisibility=hidden'
|
|
- fi # have visibility pragma bug
|
|
- fi # have visibility pragma
|
|
- fi # have visibility(default) attribute
|
|
- fi # have visibility(hidden) attribute
|
|
+ AC_DEFINE(HAVE_VISIBILITY_HIDDEN_ATTRIBUTE)
|
|
+ AC_DEFINE(HAVE_VISIBILITY_ATTRIBUTE)
|
|
+ VISIBILITY_FLAGS='-I$(DIST)/system_wrappers -include $(topsrcdir)/config/gcc_hidden.h'
|
|
+ WRAP_SYSTEM_INCLUDES=1
|
|
fi # GNU_CC
|
|
|
|
# visibility hidden flag for Sun Studio on Solaris
|
|
@@ -3280,7 +3177,7 @@ if test "$MOZ_MEMORY"; then
|
|
*-darwin*)
|
|
AC_DEFINE(MOZ_MEMORY_DARWIN)
|
|
;;
|
|
- *-*freebsd*)
|
|
+ *-*freebsd*|*-*dragonfly*)
|
|
AC_DEFINE(MOZ_MEMORY_BSD)
|
|
;;
|
|
*-android*|*-linuxandroid*)
|
|
@@ -4144,6 +4041,20 @@ AC_SUBST(CXX_VERSION)
|
|
AC_SUBST(MSMANIFEST_TOOL)
|
|
AC_SUBST(MOZ_LINKER)
|
|
|
|
+AC_MSG_CHECKING([for posix_fadvise])
|
|
+AC_TRY_LINK([#define _XOPEN_SOURCE 600
|
|
+ #include <fcntl.h>],
|
|
+ [posix_fadvise(0, 0, 0, 0);],
|
|
+ [ac_cv___posix_fadvise=true],
|
|
+ [ac_cv___posix_fadvise=false])
|
|
+
|
|
+if test "$ac_cv___posix_fadvise" = true ; then
|
|
+ AC_DEFINE(HAVE_POSIX_FADVISE)
|
|
+ AC_MSG_RESULT(yes)
|
|
+else
|
|
+ AC_MSG_RESULT(no)
|
|
+fi
|
|
+
|
|
AC_MSG_CHECKING([for posix_fallocate])
|
|
AC_TRY_LINK([#define _XOPEN_SOURCE 600
|
|
#include <fcntl.h>],
|
|
@@ -4512,6 +4423,16 @@ fi
|
|
dnl ========================================================
|
|
dnl JavaScript shell
|
|
dnl ========================================================
|
|
+ICU_LIB_NAMES=
|
|
+MOZ_NATIVE_ICU=
|
|
+MOZ_ARG_WITH_BOOL(system-icu,
|
|
+[ --with-system-icu
|
|
+ Use system icu (located with pkgconfig)],
|
|
+ MOZ_NATIVE_ICU=1)
|
|
+
|
|
+if test -n "$MOZ_NATIVE_ICU"; then
|
|
+ PKG_CHECK_MODULES(MOZ_ICU, icu-i18n >= 50.1)
|
|
+fi
|
|
|
|
AC_HAVE_FUNCS(setlocale)
|
|
AC_HAVE_FUNCS(localeconv)
|