pkgsrc/www/firefox/patches/patch-config_Makefile.in
ryoon f249fe66dc Update to 29.0
* Restore html5 audio playback under NetBSD

Changelog:

    New
    Significant new customization mode makes it easy to personalize your Web experience to access the features you use the most (learn more)

    New
    A new, easy to access menu sits in the right hand corner of Firefox and includes popular browser controls

    New
    Sleek new tabs provide an overall smoother look and fade into the background when not active

    New
    An interactive onboarding tour to guide users through the new Firefox changes

    New
    The ability to set up Firefox Sync by creating a Firefox account (learn more)

    New
    Gamepad API finalized and enabled (learn more)

    New
    HTTPS used for Yahoo Searches performed in en-US locale

    New
    Malay [ma] locale added

    Changed
    Clicking on a W3C Web Notification will switch to the originating tab

    Developer
    'box-sizing' (dropping the -moz- prefix) implemented (learn more)

    Developer
    Console object available in Web Workers (learn more)

    Developer
    Promises enabled by default (learn more)

    Developer
    SharedWorker enabled by default

    Developer
    <input type="number"> implemented and enabled

    Developer
    <input type="color"> implemented and enabled

    Developer
    Enabled ECMAScript Internationalization API

    Developer
    Add-on bar has been removed, content moved to navigation bar

    Developer
    Implemented URLSearchParams from the URL specification (see MDN for details )

    Fixed
    Various security fixes

Fixed in Firefox 29
MFSA 2014-47 Debugger can bypass XrayWrappers with JavaScript
MFSA 2014-46 Use-after-free in nsHostResolve
MFSA 2014-45 Incorrect IDNA domain name matching for wildcard certificates
MFSA 2014-44 Use-after-free in imgLoader while resizing images
MFSA 2014-43 Cross-site scripting (XSS) using history navigations
MFSA 2014-42 Privilege escalation through Web Notification API
MFSA 2014-41 Out-of-bounds write in Cairo
MFSA 2014-40 Firefox for Android addressbar suppression
MFSA 2014-39 Use-after-free in the Text Track Manager for HTML video
MFSA 2014-38 Buffer overflow when using non-XBL object as XBL
MFSA 2014-37 Out of bounds read while decoding JPG images
MFSA 2014-36 Web Audio memory corruption issues
MFSA 2014-35 Privilege escalation through Mozilla Maintenance Service Installer
MFSA 2014-34 Miscellaneous memory safety hazards (rv:29.0 / rv:24.5)
2014-04-30 15:07:17 +00:00

20 lines
905 B
Text

$NetBSD: patch-config_Makefile.in,v 1.4 2014/04/30 15:07:18 ryoon Exp $
--- config/Makefile.in.orig 2014-04-18 02:02:39.000000000 +0000
+++ config/Makefile.in
@@ -77,6 +77,15 @@ export:: $(export-preqs)
-DMOZ_NATIVE_LIBEVENT=$(MOZ_NATIVE_LIBEVENT) \
-DMOZ_NATIVE_LIBVPX=$(MOZ_NATIVE_LIBVPX) \
-DMOZ_NATIVE_ICU=$(MOZ_NATIVE_ICU) \
+ -DMOZ_NATIVE_GRAPHITE2=$(MOZ_NATIVE_GRAPHITE2) \
+ -DMOZ_NATIVE_HARFBUZZ=$(MOZ_NATIVE_HARFBUZZ) \
+ -DMOZ_NATIVE_OGG=$(MOZ_NATIVE_OGG) \
+ -DMOZ_NATIVE_THEORA=$(MOZ_NATIVE_THEORA) \
+ -DMOZ_NATIVE_VORBIS=$(MOZ_NATIVE_VORBIS) \
+ -DMOZ_NATIVE_TREMOR=$(MOZ_NATIVE_TREMOR) \
+ -DMOZ_NATIVE_OPUS=$(MOZ_NATIVE_OPUS) \
+ -DMOZ_NATIVE_SPEEX=$(MOZ_NATIVE_SPEEX) \
+ -DMOZ_NATIVE_SOUNDTOUCH=$(MOZ_NATIVE_SOUNDTOUCH) \
$(srcdir)/system-headers | $(PERL) $(topsrcdir)/nsprpub/config/make-system-wrappers.pl system_wrappers
$(INSTALL) system_wrappers $(DIST)