pkgsrc/mail/thunderbird/patches/patch-ml
ryoon 78782af087 Update to 31.0
* Update enigmail to 1.7

Changelog:
    NEW
    Autocompleting email addresses now matches against any part of the name or email (bug 529584)

    NEW
    Composing a mail to a newsgroup will now autocomplete newsgroup names (bug 61491)

    FIXED
    Insecure NTLM (pre-NTLMv2) authentication disabled (see 828183)

Fixed in Thunderbird 31
MFSA 2014-66 IFRAME sandbox same-origin access through redirect
MFSA 2014-65 Certificate parsing broken by non-standard character encoding
MFSA 2014-64 Crash in Skia library when scaling high quality images
MFSA 2014-63 Use-after-free while when manipulating certificates in the trusted cache
MFSA 2014-62 Exploitable WebGL crash with Cesium JavaScript library
MFSA 2014-61 Use-after-free with FireOnStateChange event
MFSA 2014-59 Use-after-free in DirectWrite font handling
MFSA 2014-58 Use-after-free in Web Audio due to incorrect control message ordering
MFSA 2014-57 Buffer overflow during Web Audio buffering for playback
MFSA 2014-56 Miscellaneous memory safety hazards (rv:31.0 / rv:24.7)
2014-07-27 20:04:59 +00:00

33 lines
1.1 KiB
Text

$NetBSD: patch-ml,v 1.7 2014/07/27 20:04:59 ryoon Exp $
Treat DragonFly like FreeBSD.
--- mozilla/js/src/Makefile.in.orig 2014-07-18 00:05:24.000000000 +0000
+++ mozilla/js/src/Makefile.in
@@ -20,8 +20,6 @@ run_for_side_effects := $(shell echo 'MA
STATIC_LIBRARY_NAME = js_static
LIBS = $(NSPR_LIBS)
-DIST_INSTALL = 1
-
ifdef JS_STANDALONE
SHARED_LIBRARY_LIBS += $(call EXPAND_LIBNAME_PATH,mfbt,$(DEPTH)/mfbt)
endif
@@ -226,7 +224,7 @@ endif
ifdef MOZ_SHARED_ICU
EXTRA_DSO_LDOPTS += $(MOZ_ICU_LIBS)
else
-SHARED_LIBRARY_LIBS += $(MOZ_ICU_LIBS)
+SHARED_LIBRARY_LIBS += $(filter-out -L% -l% -Wl%,$(MOZ_ICU_LIBS))
endif
# Prevent floating point errors caused by VC++ optimizations
@@ -350,7 +348,7 @@ endif
ifdef HAVE_DTRACE
$(CURDIR)/javascript-trace.h: $(srcdir)/devtools/javascript-trace.d
- dtrace -h -s $(srcdir)/devtools/javascript-trace.d -o javascript-trace.h.in
+ dtrace -x nolibs -h -s $(srcdir)/devtools/javascript-trace.d -o javascript-trace.h.in
sed -e 's/if _DTRACE_VERSION/ifdef INCLUDE_MOZILLA_DTRACE/' \
-e '/const/!s/char \*/const char */g' \
javascript-trace.h.in > javascript-trace.h