pkgsrc/mail/thunderbird/patches/patch-mozilla_gfx_skia_Makefile.in
ryoon 78782af087 Update to 31.0
* Update enigmail to 1.7

Changelog:
    NEW
    Autocompleting email addresses now matches against any part of the name or email (bug 529584)

    NEW
    Composing a mail to a newsgroup will now autocomplete newsgroup names (bug 61491)

    FIXED
    Insecure NTLM (pre-NTLMv2) authentication disabled (see 828183)

Fixed in Thunderbird 31
MFSA 2014-66 IFRAME sandbox same-origin access through redirect
MFSA 2014-65 Certificate parsing broken by non-standard character encoding
MFSA 2014-64 Crash in Skia library when scaling high quality images
MFSA 2014-63 Use-after-free while when manipulating certificates in the trusted cache
MFSA 2014-62 Exploitable WebGL crash with Cesium JavaScript library
MFSA 2014-61 Use-after-free with FireOnStateChange event
MFSA 2014-59 Use-after-free in DirectWrite font handling
MFSA 2014-58 Use-after-free in Web Audio due to incorrect control message ordering
MFSA 2014-57 Buffer overflow during Web Audio buffering for playback
MFSA 2014-56 Miscellaneous memory safety hazards (rv:31.0 / rv:24.7)
2014-07-27 20:04:59 +00:00

15 lines
476 B
Text

$NetBSD: patch-mozilla_gfx_skia_Makefile.in,v 1.1 2014/07/27 20:04:59 ryoon Exp $
--- mozilla/gfx/skia/Makefile.in.orig 2014-07-18 00:05:20.000000000 +0000
+++ mozilla/gfx/skia/Makefile.in
@@ -15,6 +15,10 @@ ifeq (qt,$(MOZ_WIDGET_TOOLKIT))
OS_CXXFLAGS += $(MOZ_CAIRO_CFLAGS) $(MOZ_PANGO_CFLAGS) $(CAIRO_FT_CFLAGS)
endif
+ifdef MOZ_NATIVE_HARFBUZZ
+OS_CXXFLAGS += $(MOZ_HARFBUZZ_CFLAGS)
+endif
+
include $(topsrcdir)/config/rules.mk
ifeq ($(CPU_ARCH)_$(GNU_CC),arm_1)