* Update enigmail to 1.7 Changelog: NEW Autocompleting email addresses now matches against any part of the name or email (bug 529584) NEW Composing a mail to a newsgroup will now autocomplete newsgroup names (bug 61491) FIXED Insecure NTLM (pre-NTLMv2) authentication disabled (see 828183) Fixed in Thunderbird 31 MFSA 2014-66 IFRAME sandbox same-origin access through redirect MFSA 2014-65 Certificate parsing broken by non-standard character encoding MFSA 2014-64 Crash in Skia library when scaling high quality images MFSA 2014-63 Use-after-free while when manipulating certificates in the trusted cache MFSA 2014-62 Exploitable WebGL crash with Cesium JavaScript library MFSA 2014-61 Use-after-free with FireOnStateChange event MFSA 2014-59 Use-after-free in DirectWrite font handling MFSA 2014-58 Use-after-free in Web Audio due to incorrect control message ordering MFSA 2014-57 Buffer overflow during Web Audio buffering for playback MFSA 2014-56 Miscellaneous memory safety hazards (rv:31.0 / rv:24.7)
20 lines
1 KiB
Text
20 lines
1 KiB
Text
$NetBSD: patch-mozilla_storage_src_moz.build,v 1.1 2014/07/27 20:05:00 ryoon Exp $
|
|
|
|
--- mozilla/storage/src/moz.build.orig 2014-07-18 00:05:51.000000000 +0000
|
|
+++ mozilla/storage/src/moz.build
|
|
@@ -48,11 +48,14 @@ FINAL_LIBRARY = 'storagecomps'
|
|
# (such as NSS) might trigger an initialization of sqlite and allocation
|
|
# of memory using the default allocator, prior to the storage service
|
|
# registering its allocator, causing memory management failures (bug 938730).
|
|
+# However, this is not an issue if both the jemalloc allocator and the default
|
|
+# allocator are the same thing.
|
|
#
|
|
# Note: On Windows our sqlite build assumes we use jemalloc. If you disable
|
|
# MOZ_STORAGE_MEMORY on Windows, you will also need to change the "ifdef
|
|
# MOZ_MEMORY" options in db/sqlite3/src/Makefile.in.
|
|
-if CONFIG['MOZ_MEMORY'] and not CONFIG['MOZ_NATIVE_SQLITE']:
|
|
+if CONFIG['MOZ_MEMORY'] and (not CONFIG['MOZ_NATIVE_SQLITE']
|
|
+ or CONFIG['MOZ_NATIVE_JEMALLOC']):
|
|
if CONFIG['OS_TARGET'] != 'Android':
|
|
DEFINES['MOZ_STORAGE_MEMORY'] = True
|
|
|