Use the teTeX/module.mk and honor PKG_LOCALTEXMFPREFIX make sure advi's makefile do not run texhash by itself (rely on module.mk for that) Many patches removing warnings (from advi's cvs) bump PKGREVISION, and remove broken-in
20 lines
753 B
Text
20 lines
753 B
Text
$NetBSD: patch-ad,v 1.1 2006/04/19 13:13:05 tonio Exp $
|
|
|
|
--- symbol.ml.orig 2004-10-01 13:13:35.000000000 +0200
|
|
+++ symbol.ml
|
|
@@ -555,7 +555,6 @@ let valid position i = i >= 0 && i < Arr
|
|
let around b x y =
|
|
try
|
|
let position = position x y in
|
|
- let space_ref = position.history.(position.first) in
|
|
let valid = valid position in
|
|
let rec skip_spaces move i =
|
|
if valid i then
|
|
@@ -576,7 +575,6 @@ let around b x y =
|
|
| Rule (_, _) -> return w
|
|
| _ ->
|
|
if pre <> dummy_symbol && above pre h <> 0 then return w else
|
|
- let c = symbol_name pre h in
|
|
let add x y = if move 0 > 0 then x ^ y else y ^ x in
|
|
word move i (add (true_symbol_name h) w) next
|
|
else -1, w in
|