ff60c62de7
the UI ported to qt4 (documents from pkgsrc/scribus can be imported, but not the other way)
40 lines
2 KiB
Text
40 lines
2 KiB
Text
$NetBSD: patch-ah,v 1.1.1.1 2010/12/13 11:49:44 drochner Exp $
|
|
|
|
--- scribus/CMakeLists.txt.orig 2010-10-31 10:44:16.000000000 +0000
|
|
+++ scribus/CMakeLists.txt
|
|
@@ -723,13 +723,13 @@ ELSE(WIN32)
|
|
ENDIF(WIN32)
|
|
|
|
##TEST FIX FOR 6897
|
|
-IF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
+IF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
|
|
# Use the -E / --export-dynamic flag to ensure that symbols in the Scribus
|
|
# binary are in the public symbol table for plugins. The symbols must also
|
|
# be set as SCRIBUS_API if we're building with -fvisibility=hidden .
|
|
# Should fix bug 6897 .
|
|
SET_TARGET_PROPERTIES(${EXE_NAME} PROPERTIES LINK_FLAGS -Wl,-E)
|
|
-ENDIF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
+ENDIF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
|
|
IF (GCC AND NOT WIN32)
|
|
# Use the -E / --export-dynamic flag to ensure that symbols in the Scribus
|
|
# binary are in the public symbol table for plugins. The symbols must also
|
|
@@ -767,9 +767,9 @@ TARGET_LINK_LIBRARIES(${EXE_NAME}
|
|
|
|
# required to resolve symbols from libdl when ld is called with --no-add-needed
|
|
# #9310 for the OpenBSD addition
|
|
-IF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
+IF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
|
|
TARGET_LINK_LIBRARIES(${EXE_NAME} dl)
|
|
-ENDIF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
+ENDIF(UNIX AND NOT CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" AND NOT CMAKE_SYSTEM_NAME STREQUAL "NetBSD")
|
|
|
|
# #9311 for the OpenBSD addition
|
|
IF(CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" OR CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
@@ -866,6 +866,7 @@ IF(NOT WANT_NOHEADERINSTALL)
|
|
PATTERN "manpages" EXCLUDE
|
|
PATTERN "old" EXCLUDE
|
|
PATTERN ".svn" EXCLUDE
|
|
+ PATTERN "CMakeFiles" EXCLUDE
|
|
)
|
|
ELSE(NOT WANT_NOHEADERINSTALL)
|
|
MESSAGE(STATUS "No source header files will be installed")
|