pkgsrc/math/scilab/patches/patch-ac
dmcmahill 0ca3e77ceb Update to scilab-2.6
Thanks to the scilab folks at INRIA for helping us get rid of 9 more patches!

From the CHANGES file:

                     Main Changes Scilab 2.5 -> 2.6
                     ==============================
NEW FUNCTIONALITIES
===================
Automatic graphic rescaling when combining 2D plots, axis handling

Isometric 3D plots. Thanks to Enrico Segre

3D plots shading. Thanks to Stephane MOTTELET

Error messages handling

Grep function added

Modeless message box added

Profiling of functions execution added

Real time simulation in Scicos. Thanks to Anders Blomdell

Scicos diagram linearization and fixed point computation

OTHERS IMPROVEMENTS
===================
A more professional licence

Input/Output improved (carriage return at the end of the file are not
required anymore, OS independent ascii file input, handling of opened
files )

More complete mexlib for MatlabV mex interface.

Many bug corrected in integer types manipulation

API improved, many examples given

A better window management under KDE

A better plugin interface (help, demos,...) and new Scilab functions for
building and loading interfaces.

Interactive demos for ODE and DAE solving added

Scicos' GUI improved, customizable keyboard shortcuts added

Default list, tlist and mlist display can be overloaded

It is now possible to draw dashed lines in color. Background now work
with postscript driver. Easiest argument passing to plot2d, plot3d,...
GIF driver bugs fixed.

INCOMPATIBLITY
==============
help and scicos palettes handling have changed.

Fraclab toolbox has been moved to the contributions part and is no
more  included in the package

The Communication Toolbox (geci) is now obsolete. It will be removed in
next release. Use PVM instead.
2001-04-08 16:25:27 +00:00

27 lines
843 B
Text

$NetBSD: patch-ac,v 1.4 2001/04/08 16:25:28 dmcmahill Exp $
check for the fortran libs. We need to check this way
to keep compatibility with both f2c and f77 rather than
hard coding something like "-lg2c".
--- configure.in.orig Mon Mar 26 07:08:33 2001
+++ configure.in Fri Mar 30 06:08:18 2001
@@ -112,4 +112,12 @@
fi
+##################################################
+## Fortran libraries required for creating fortran
+## shared libraries. In particular this is needed
+## for the lapack examples when using f2c. This
+## will set the FLIBS variable.
+##################################################
+AC_F77_LIBRARY_LDFLAGS
+
#############################################
## Compilers and options according to machine
@@ -1339,4 +1347,5 @@
AC_SUBST(LDFLAGS)
AC_SUBST(LIBS)
+AC_SUBST(FLIBS)
#AC_SUBST(CC)
AC_SUBST(CFLAGS)