bd1ca5cee6
Changelog: NEW A Menu Button is now shown to new users by default NEW Tabs are now drawn in the title bar on Windows FIXED An issue causing spell-checking only parts of words in Thunderbird 16 is now fixed (790475) FIXED An issue causing Thunderbird 16 to repeatedly download emails is now fixed (806760) FIXED RSS feeds can now be viewed in the Wide View Layout (531397) FIXED Various fixes and performance improvements FIXED Various security fixes CHANGED Mac OS X 10.5 is no longer supported Security fixes: Fixed in Thunderbird 17 MFSA 2012-106 Use-after-free, buffer overflow, and memory corruption issues found using Address Sanitizer MFSA 2012-105 Use-after-free and buffer overflow issues found using Address Sanitizer MFSA 2012-103 Frames can shadow top.location MFSA 2012-101 Improper character decoding in HZ-GB-2312 charset MFSA 2012-100 Improper security filtering for cross-origin wrappers MFSA 2012-99 XrayWrappers exposes chrome-only properties when not in chrome compartment MFSA 2012-97 XMLHttpRequest inherits incorrect principal within sandbox MFSA 2012-96 Memory corruption in str_unescape MFSA 2012-94 Crash when combining SVG text on path with CSS MFSA 2012-93 evalInSanbox location context incorrectly applied MFSA 2012-92 Buffer overflow while rendering GIF images MFSA 2012-91 Miscellaneous memory safety hazards (rv:17.0/ rv:10.0.11)
28 lines
686 B
Text
28 lines
686 B
Text
$NetBSD: patch-mozilla_media_libcubeb_src_Makefile.in,v 1.1 2012/11/23 07:17:54 ryoon Exp $
|
|
|
|
--- mozilla/media/libcubeb/src/Makefile.in.orig 2012-11-19 22:42:33.000000000 +0000
|
|
+++ mozilla/media/libcubeb/src/Makefile.in
|
|
@@ -24,10 +24,6 @@ endif
|
|
|
|
ifeq ($(OS_TARGET),Android)
|
|
# No Android implementation of libcubeb yet.
|
|
-else ifeq ($(OS_TARGET),Linux)
|
|
-CSRCS = \
|
|
- cubeb_alsa.c \
|
|
- $(NULL)
|
|
endif
|
|
|
|
ifeq ($(OS_TARGET),Darwin)
|
|
@@ -42,6 +38,12 @@ CSRCS = \
|
|
$(NULL)
|
|
endif
|
|
|
|
+ifdef MOZ_ALSA
|
|
+CSRCS = \
|
|
+ cubeb_alsa.c \
|
|
+ $(NULL)
|
|
+endif
|
|
+
|
|
ifdef MOZ_PULSEAUDIO
|
|
CSRCS = \
|
|
cubeb_pulse.c \
|