d2e70b0ab3
* Update Mozilla Lightning to 1.7 * Update Enigmail to 1.4.4 (functionality is not tested yet; should be updated) * Regen patches Changelog: NEW Multi-Channel Chat: You now can enjoy real time conversation with your contacts, right from your favorite messaging application. NEW Do Not Track: This option has been implemented as an addition to Search the Web. NEW Ubuntu One is now supported in Filelink - the option to upload large attachments to online storage services. NEW New User Interface: Thunderbird is replicating the new look and feel of Mozilla Firefox in an effort to provide a similar user experience across all Mozilla software desktop or mobile and all platforms. FIXED Various fixes and performance improvements FIXED Various security fixes MFSA 2012-72 Web console eval capable of executing chrome-privileged code MFSA 2012-70 Location object security checks bypassed by chrome code MFSA 2012-68 DOMParser loads linked resources in extensions when parsing text/html MFSA 2012-67 Installer will launch incorrect executable following new installation MFSA 2012-65 Out-of-bounds read in format-number in XSLT MFSA 2012-64 Graphite 2 memory corruption MFSA 2012-63 SVG buffer overflow and use-after-free issues MFSA 2012-62 WebGL use-after-free and memory corruption MFSA 2012-61 Memory corruption with bitmap format images with negative height MFSA 2012-59 Location object can be shadowed using Object.defineProperty MFSA 2012-58 Use-after-free issues found using Address Sanitizer MFSA 2012-57 Miscellaneous memory safety hazards (rv:15.0/ rv:10.0.7)
27 lines
564 B
Text
27 lines
564 B
Text
$NetBSD: patch-mozilla_storage_src_Makefile.in,v 1.3 2012/09/02 06:43:43 ryoon Exp $
|
|
|
|
--- mozilla/storage/src/Makefile.in.orig 2012-08-25 00:31:30.000000000 +0000
|
|
+++ mozilla/storage/src/Makefile.in
|
|
@@ -34,6 +34,22 @@ DEFINES += -DMOZ_STORAGE_MEMORY
|
|
endif
|
|
endif
|
|
|
|
+ifeq ($(OS_ARCH),DragonFly)
|
|
+DEFINES += -DXP_BSD
|
|
+endif
|
|
+
|
|
+ifeq ($(OS_ARCH),FreeBSD)
|
|
+DEFINES += -DXP_BSD
|
|
+endif
|
|
+
|
|
+ifeq ($(OS_ARCH),NetBSD)
|
|
+DEFINES += -DXP_BSD
|
|
+endif
|
|
+
|
|
+ifeq ($(OS_ARCH),FreeBSD)
|
|
+DEFINES += -DXP_BSD
|
|
+endif
|
|
+
|
|
EXPORTS_NAMESPACES = mozilla/storage
|
|
|
|
EXPORTS_mozilla/storage = \
|