pkgsrc/net/ipa/patches/patch-aa
salo 7d2002d261 Updated to version 1.3.4.
Addresses PR pkg/21719 by Andrey Simonenko (MAINTAINER).

Changes:
- don't include bsd.pkg.install.mk if USE_PKGINSTALL is already set
- restrict to *BSD
- install /var/ipa directory
- fix paths in manual pages
- better rc scripts, NetBSD native and generic one
- DESCR has 80 columns

1.3.4:
======
- Added support for PF from OpenBSD 3.3
- Minor changes
2003-05-30 11:53:16 +00:00

59 lines
2.1 KiB
Text

$NetBSD: patch-aa,v 1.9 2003/05/30 11:53:17 salo Exp $
--- Makefile.orig 2003-04-08 21:18:15.000000000 +0200
+++ Makefile 2003-05-30 13:15:24.000000000 +0200
@@ -38,7 +38,7 @@
# -Ox - optimize;
# -g - produce debugging information.
#
-CFLAGS= -Wall -O1 -g
+#CFLAGS= -Wall -O1 -g
#
# PREFIX - prefix for all below listed paths
@@ -58,7 +58,7 @@
#
# DST_ETC_DIR - where to install template configuration
#
-DST_ETC_DIR= ${PREFIX}/etc
+DST_ETC_DIR= ${DST_EXAMPLE_DIR}
#
# DST_RC_DIR - where to install sample rc-script
@@ -81,10 +81,10 @@
#
# INSTALL_* variables
#
-INSTALL_MAN= ${INSTALL} -c -g wheel -o root -m 0444
-INSTALL_DATA= ${INSTALL} -c -g wheel -o root -m 0444
-INSTALL_PROGRAM= ${INSTALL} -c -g wheel -o root -m 0555
-INSTALL_SCRIPT= ${INSTALL} -c -g wheel -o root -m 0500
+INSTALL_MAN= ${BSD_INSTALL_MAN}
+INSTALL_DATA= ${BSD_INSTALL_DATA}
+INSTALL_PROGRAM= ${BSD_INSTALL_PROGRAM}
+INSTALL_SCRIPT= ${BSD_INSTALL_SCRIPT}
INSTALL_MAN_DIR= ${INSTALL} -d -m 0555 -g wheel -o root
INSTALL_DATA_DIR= ${INSTALL} -d -m 0555 -g wheel -o root
@@ -207,21 +207,8 @@
${INSTALL_PROGRAM} ipa ipastat ${DST_BIN_DIR}
${INSTALL_MAN} man/ipa.5 man/ipa.conf.5 ${DST_MAN_DIR}/man5
${INSTALL_MAN} man/ipa.8 man/ipastat.8 ${DST_MAN_DIR}/man8
-.if !exists(${DST_MAN_DIR}/ru_RU.KOI8-R/man5)
- ${INSTALL_MAN_DIR} ${DST_MAN_DIR}/ru_RU.KOI8-R/man5
-.endif
-.if !exists(${DST_MAN_DIR}/ru_RU.KOI8-R/man8)
- ${INSTALL_MAN_DIR} ${DST_MAN_DIR}/ru_RU.KOI8-R/man8
-.endif
-.if !exists(${DST_MAN_DIR}/ru_SU.KOI8-R)
- ${LN} -s ${DST_MAN_DIR}/ru_RU.KOI8-R ${DST_MAN_DIR}/ru_SU.KOI8-R
-.endif
- ${INSTALL_MAN} man/ru_RU.KOI8-R/ipa.5 man/ru_RU.KOI8-R/ipa.conf.5 ${DST_MAN_DIR}/ru_RU.KOI8-R/man5
- ${INSTALL_MAN} man/ru_RU.KOI8-R/ipa.8 man/ru_RU.KOI8-R/ipastat.8 ${DST_MAN_DIR}/ru_RU.KOI8-R/man8
- ${INSTALL_DATA_DIR} ${DST_EXAMPLE_DIR}
${INSTALL_DATA} examples/* ${DST_EXAMPLE_DIR}
.if exists(${DST_RC_DIR})
- ${INSTALL_SCRIPT} etc/ipa.sh.sample ${DST_RC_DIR}
.else
@${ECHO}
@${ECHO} ">> Can't find directory ${DST_RC_DIR}, the ipa.sh.sample file was not installed (not a problem)."