pkgsrc/audio/libcanberra/options.mk
prlw1 55c616c24f Update libcanberra to 0.30
Motivation: Version 0.30 released; Port to GStreamer 1.0.

I believe the warning in doc/TODO:

   o libcanberra-0.28 [drops support for GNOME2; don't update for now -- wiz]

comes from:

Version 0.28 released; Hook properly into GNOME 3.0 sessions; this
drops support for GNOME 2.0 sessions, but not applications.

which essentially comes from:

index aa0a3a3..210d2c1 100644
--- a/src/libcanberra-login-sound.desktop.in
+++ b/src/libcanberra-login-sound.desktop.in
@@ -4,6 +4,6 @@ Name=GNOME Login Sound
 Comment=Plays a sound whenever you log in
 Exec=@bindir@/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
 OnlyShowIn=GNOME;
-AutostartCondition=GNOME /desktop/gnome/sound/event_sounds
+AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
 X-GNOME-Autostart-Phase=Application
 X-GNOME-Provides=login-sound

AFAICT, given that I have not found a desktop-login audio file anywhere
in pkgsrc (there is a login file), --id="desktop-login" will never match,
so we can't break something which doesn't work. If this analysis is wrong,
changing one line in 2 .desktop files is trivial. Relying on
gstreamer 0.10 working is worse.
2018-11-29 11:20:18 +00:00

23 lines
508 B
Makefile

# $NetBSD: options.mk,v 1.3 2018/11/29 11:20:18 prlw1 Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.libcanberra
PKG_SUPPORTED_OPTIONS= gtk gtk3
PKG_SUGGESTED_OPTIONS= gtk gtk3
.include "../../mk/bsd.options.mk"
PLIST_VARS+= gtk-any gtk gtk3
.if !empty(PKG_OPTIONS:Mgtk) || !empty(PKG_OPTIONS:Mgtk3)
PLIST.gtk-any= yes
.endif
.if !empty(PKG_OPTIONS:Mgtk)
PLIST.gtk= yes
.include "../../x11/gtk2/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mgtk3)
PLIST.gtk3= yes
.include "../../x11/gtk3/buildlink3.mk"
.endif