pkgsrc/www/libwww/patches/patch-ae
fredb fc188fc5fc Rely on the fact that shared libraries can encode run-time dependencies
on other libraries, on both ELF and (NetBSD/)a.out, to make
libwwwssl.so.?.? depend on the correct openssl shared libraries, as
determined by the setting of ${SSLBASE} in bsd.pkg.mk. This closes PR
pkg/12570, and has the additional advantage that programs that _do_ _not_
need to link in "-lwwwssl" won't get "-lssl" or "-lcrypto" at all.

Also, make"w3c" and "www" build again with USE_SOCKS=4.
2001-04-20 12:33:52 +00:00

19 lines
473 B
Text

$NetBSD: patch-ae,v 1.4 2001/04/20 12:33:53 fredb Exp $
--- Library/src/SSL/Makefile.am.orig Tue Jun 20 06:01:34 2000
+++ Library/src/SSL/Makefile.am
@@ -39,13 +39,12 @@
HTSSLhttps.h \
HTSSLhttps.c
-libwwwssl_la_LDFLAGS = -rpath $(libdir)
+libwwwssl_la_LDFLAGS = @SSLLIBS@ -rpath $(libdir)
LDADD = \
libwwwssl.la
INCLUDES = \
- -I/usr/local/include \
-I${top_srcdir}/modules/md5 \
-I${top_srcdir}/modules/expat/xmlparse \
-I$(top_srcdir)/Library/src \