pkgsrc/net/icinga-base/patches/patch-Makefile.in
ryoon 7a91e00aff Update 1.9.4
* Switch to 1.9.x branch
* Fix CVE-2013-7106 and CVE-2013-7108

Changelog:
1.9.4 - 13/12/2013

FIXES
* classic ui: fix status output in JSON format not including short and long plugin output properly #5217 - RB
* classic ui: fix possible buffer overflows #5250 - RB
* classic ui: fix Off-by-one memory access in process_cgivars() #5251 - RB


1.9.3 - 07/07/2013

FIXES
* core: fix init script status exit codes on not running daemon and present pid file #4243 - MF

* idoutils: fix workaround on libdbi fetch_next_row() bug applied for postgresql too, causing faulty queries #4367 - MF


1.9.2 - 30/06/2013

FIXES
* core: fix bug with non-ASCII (> 127) illegal macro output characters on char-to-int cast (Jason Young) #4211 - MF
* core: bail early if main config file cannot be read - MF

* classic ui: fixed searching hostgroup results in wrong 'all' view filter urls #4206 - RB
* classic ui: fix URL construction issue in icinga_reload_scroll_position() javascript (Karsten Sühring) #4233 - MF

* idoutils: fix mysql: output/perfdata limits cut escaped string leaving '\' at the end (Yannik Charton) #4196 - MF
* idoutils: bugfixes for socket queue, transactions and libdbi handling #4049 - GB
* idoutils: fix ido2db gradually consumes more and more CPU time with time #4210 - CF
* idoutils: fix wrong clob freeing in eventhandlers #4357 - TD


1.9.1 - 22/05/2013

FIXES
* core: fix objects.cache does not get updated on (re)start, but config verify (Christian Ruppert) #4155 - MF

* classic ui: fixed UNICODE characters in JSON output from getting discarded #4193 - RB

* idoutils: fix segfaults on reload with multiple neb modules of the same binary #4033 - MF


1.9.0 - 07/05/2013

NOTES
* idoutils uses a socket queue and transactions for large object dumps! #3527 #3533
* ido2db.cfg enable_sla is now deprecated! #3450
* icinga.cfg event_profiling_enabled is now deprecated! #4054

ENHANCEMENTS
* core: increase performance with hash comparing hosts/services on config read #3722 - GB
* core: introduce warning level -vv on config verification #3510 - MF
* core: refuse to start if neb modules fail to load (Andreas Ericsson, op5 Team) #3812 - MF
* core: keep logfile open, reducing open/close performance decreases (Andreas Ericsson, op5 Team) #3390 - MF
* core: enhance illegal macro character processing performance (Andreas Ericsson, op5 Team) #3389 - MF
* core: add the notification type by string to debug logs; set CUSTOM=8, STALKING=9 (Andreas Ericsson, op5 Team) #3818 - MF
* core: skip writing status.dat if explicitely set to /dev/null (e.g. when using alternate data retrieval methods like IDOUtils) (Andreas Ericsson, op5 Team) #3819 - MF
* core: avoid writing objects.cache if set to /dev/null (Andreas Ericsson, op5 Team) #3819 - MF
* core: increase performance on host->service relation counter (config reading, flapping) #3820 - MF
* core: fix unable to exclude hostgroups when using nested hostgroups (Alexander Sulfrian) #2619 - MF

* classic ui: increase performance with hash comparing hosts/services to show/filter #3722 - GB
* classic ui: Add "set_expire_ack_by_default" to cgi configuration #3476 - CF
* classic ui: Add "send_ack_notifications" to cgi configuration (TheCry) #3467 - CF
* classic ui: Changed field size for hours to 4 when setting flexible downtime #3484 - RB
* classic ui: Added process status to JSON response #3172 - RB
* classic ui: Added date/time selection to 'log file navigation' #3168 - RB
* classic ui: Added setting focus to main frame on first site load #3202 - RB
* classic ui: Made sort buttons larger #3814 - RB
* classic ui: Made classic ui work standalone #3869 - RB
* classic ui: add 'executed command' to extinfo.cgi linking to command expander #3901 - MF

* idoutils: use transactions for large object dumps #3527 - GB
* idoutils: add socket queue proxy addressing core reload problems #3533 - GB
* idoutils: add more indexes for sla reporting #3649 - MF
* idoutils: Oracle - change output fields to clob #3412 - TD

* install: set --enable-idoutils/event-broker to true as default configure flags #3813 - MF
* install: add lighttp config samples to contrib/lighttp #2253 - RB
* install: add --with-httpd-conf-file to allow specific apache config to be installed #3962 - MF
* install: make install-webconf-auth installs htpasswd.users automatically, allowing default icingaadmin login out-of-the-box #3963 - MF
* install: add 'make classicui-standalone' and 'make install-classicui-standalone' #3963 - MF

* docs: Temporary files should mention temp_file option in icinga.cfg #3748 - WN
* docs: add upgrade/troubleshooting notes about invisible icinga web cronks/modules after upgrade #3939 - WN
* docs: make install-webconf-auth installs htpasswd.user with icingaadmin credentials #3964 - WN
* docs: icinga web 1.9: new menu style (smaller icons) #3944 - MF
* docs: icinga web 1.9: new filtering methods #3947 - MF
* docs: add userpreferences.xml to icinga web configs #3991 - WN
* docs: add web gui comparison to beginners #3907 - WN


FIXES
* core: fix faulty macro cleaning, replacing spaces with pluses where they shouldn't be cleaned #3397 - MF
* core: fix macro escaping logs incorrect warning for $$escapes #3404 - MF
* core: fix wrong escalation notification due to state based escalation range behaviour changes #3441 - MF
* core: change ownership of (debug) log file before dropping privileges (Andreas Ericsson, op5 Team) #3521 - MF
* core: fix keep_unknown_macros still exposes wrong warnings to logs #3725 - MF
* core: fix host_check, last_check == next_check wrong in scheduling queue #2195 - MF
* core: fix triggered downtimes for child hosts are missing after icinga restart (thx Michael Lucka) #3390 - MF
* core: fix services with empty hostgroups aren't processed even if it has host_name specified (allow_empty_hostgroups=1) (thx Viranch Metha) #3736 - MF
* core: revamp USE_LTDL definitions in nebmods (Andreas Ericsson, op5 Team) #3817 - MF
* core: fix checkresult reaper cleanup fails due to relative file path #3937 - MaF
* core: do not export host/servicegroupmembers as environment macros in large installations #3859 - MF
* core: set default permissions to icinga/ido2db binaries to 755 #3902 - GB

* classic ui: fix cmd.cgi does not honor commandpipe location; overwrites from empty environment variable #3418 - MF
* classic ui: fixed Double-listed host dependencies in host extinfo.cgi #3295 - RB
* classic ui: fixed sort_icinga_logfiles_by_name() in readlogs.c fails to take NULL pointers into consideration #3398 - CF
* classic ui: fixed committing acknowledgement cmd negates flags for send_notification and sticky_ack #3329 - RB
* classic ui: fixed backtrack_archives only getting calculated on a daily log rotation basis #3416 - RB
* classic ui: fixed invalid freeing of last_check in 'scheduling queue' for first time checks #3444 - RB
* classic ui: fixed Warning and Unknown States are mixed up in Alert Summary Report #3488 - RB
* classic ui: fixed extinfo.cgi shows localtime(0) instead of "NOT SET" when global notifications are not set to expire #3482 - RB
* classic ui: fixed CGIs generating invalid html code/ json when throwing error #3507 - RB
* classic ui: fixed JSON output is insufficiently escaped #3541 - RB
* classic ui: fixed segfault when reading malformed log entries #3528 - RB
* classic ui: "fixed" Incorrect positioning status popup in statusmap #3861 - RB
* classic ui: fixed possible NULL dereference-bug in summary.c #3740 - RB
* classic ui: fixed Command expansion problem with percentage signs #3929 - RB
* classic ui: cleaned up the jquery-ui includes to allow debian pkg dependencies #3808 - RB
* classic ui: fixed Trigger Time in Scheduled Downtime displaying 01-01-1970 01:00:00 when not triggered #3980 - RB
* classic-ui: fixed host and service names are not allowed to have a '+' included #1843 - RB

* idoutils: fix many memory leaks in ido2db on dbi_result_free and others (thx Klaus Wagner) #3406 - MF
* idoutils: fix ido2db crashes when Oracle queries fail #3324 - GB
* idoutils: fix ORA-1461 writing data to varchar2 exceeding field size limit output, command_arg and commandline data written to Oracle #3324 #3325 - TD
* idoutils: fix unsafe handling of dbi_conn_sequence_last, rewrite last_insert_id/sequence fetching #3408 - MF
* idoutils: fix ido2db does not cleanly exit the client on wrong schema version check in db_hello #3419 - MF
* idoutils: fix FROM_UNIXTIME(NULL) does not work with MySQL 5.0.x #3399 #3466 - CF
* idoutils: fix unknown column contactaddress_id (thx fmbiete) #3483 - MF
* idoutils: fix empty output/perfdata segfaults for mysql string truncate #3516 - MF
* idoutils: unlink leftover socket on startup, if using unix sockets - MF
* idoutils: fix long output data causes wrong data in database #2342 - MF
* idoutils: fix idomod leaks memory on core reload #3749 - GB
* idoutils: add workaround fix for num_rows_affected broken in libdbi/mariadb, returned ids are 0 #3728 - MF

* install: drop unused daemon-init-readhat script (spec uses daemon-init) #3402 - MF
* install: fix broken configure ssl detection for idoutils on ubuntu/debian (Oliver Skibbe) #3413 - MF
* install: fix ido2db initscript uses same chkconfig line as icinga (Dirk Götz) #3490 - MF
* install: fix configure does not detect AIX6/7 properly #3895 - MF
* install: fix STATEDIR creation during make install #3869 - MF

* docs: add missing cmd_mod description in cgi params #3438 - MF
* docs: search_string as cgi GET param works also for status.cgi #3451 - MF
* docs: fix typo pqsql -> pgsql #3461 - WN
* docs: recurring downtimes: should tell about dev/experimental state living in contrib/ better #3647 - WN
* docs: middle-clicking on TOC links doesn't open pages in new tab #3561 - WN

* icinga.spec: add idoutils as transitional package (thx Stefan Marx, Michael Grüner) #3640 - MF
* icinga.spec: fix double %{logdir}/gui/ definitions in icinga and icinga-gui (thx René Koch) #3802 - MF

CHANGES

* ido2db.cfg: enable_sla is now deprecated! #3450
* icinga.cfg: event_profiling_enabled is now deprecated! #4054

* icinga.cfg: enable_state_based_escalation_ranges=0 (disabled if not set) fix for #3441
* icinga.cfg: set status_file=/dev/null to disable its creation #3819
* icinga.cfg: set object_cache_file=/dev/null to disable its creation #3819

* idoutils: use transactions for large object dumps #3527
* idoutils: add socket queue proxy addressing core reload problems #3533

* core: -v param can be used more than once #3510
* core: 'Warning: Host ... has no service associated with it!' now happens only in icinga -vv icinga.cfg #3510
* core: refuse to start if neb modules fail to load #3812
* core: notification type nr CUSTOM=8 and STALKING=9 (reflected in idoutils tables) #3818
* core: using nested hostgroups you can exclude (!) hostgroup_members #2619
* core: host/servicegroupmembers are not exported as environment macros #3859
	** if enable_environment_macros=1
	** and use_large_installation_tweaks=1


* icinga.spec: add idoutils as transitional package #3640

* install: set --enable-idoutils/event-broker to true as default configure flags #3813
* install: add --with-httpd-conf-file to allow specific apache config to be installed #3962
	** this is important when installing standalone classic ui for e.g. Icinga2
* install: make install-webconf-auth installs htpasswd.users, allowing default icingaadmin login out-of-the-box #3963
* install: add --enable-classicui-standalone #3869
	** sets cgi.cfg standalone_installation=1
* install: add 'make classicui-standalone' and 'make install-classicui-standalone' #3963
	** this will install classic ui standalone, if enabled
* install: default permissions for icinga/ido2db binaries are now 755 #3902
2013-12-31 03:28:39 +00:00

204 lines
12 KiB
Text

$NetBSD: patch-Makefile.in,v 1.2 2013/12/31 03:28:39 ryoon Exp $
--- Makefile.in.orig 2013-12-13 12:54:34.000000000 +0000
+++ Makefile.in
@@ -38,7 +38,7 @@ CHECKRESULTDIR=@CHECKRESULTDIR@
EXTCMDFILEDIR=@EXTCMDFILEDIR@
EVENTHANDLERDIR=@EVENTHANDLERDIR@
P1FILELOC=@P1FILELOC@
-CFGDIR=@sysconfdir@
+CFGDIR=@prefix@/share/examples/icinga
BINDIR=@bindir@
LIBDIR=@libdir@
CGIDIR=@sbindir@
@@ -380,14 +380,14 @@ install-unstripped:
$(MAKE) install-basic
install-basic:
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(STATEDIR)
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBEXECDIR)
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)/archives
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CHECKRESULTDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(STATEDIR)
+ ${BSD_INSTALL_LIB_DIR} $(DESTDIR)$(LIBEXECDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(LOGDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(LOGDIR)/archives
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(CHECKRESULTDIR)
if [ $(INSTALLPERLSTUFF) = yes ]; then \
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(P1FILELOC); \
- $(INSTALL) -m 664 $(INSTALL_OPTS) p1.pl $(DESTDIR)$(P1FILELOC); \
+ ${BSD_INSTALL_SCRIPT_DIR} $(DESTDIR)$(P1FILELOC); \
+ ${BSD_INSTALL_SCRIPT} p1.pl $(DESTDIR)$(P1FILELOC); \
fi;
@echo ""
@@ -426,27 +426,27 @@ install-basic:
@echo ""
install-cgiconf:
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/cgiauth.cfg $(DESTDIR)$(CFGDIR)/cgiauth.cfg
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(CFGDIR)
+ ${BSD_INSTALL_DATA} sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg
+ ${BSD_INSTALL_DATA} sample-config/cgiauth.cfg $(DESTDIR)$(CFGDIR)/cgiauth.cfg
install-config: install-cgiconf
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/objects
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/conf.d
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/modules
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/icinga.cfg $(DESTDIR)$(CFGDIR)/icinga.cfg
- $(INSTALL) -b -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/templates.cfg $(DESTDIR)$(CFGDIR)/objects/templates.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/commands.cfg $(DESTDIR)$(CFGDIR)/objects/commands.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/contacts.cfg $(DESTDIR)$(CFGDIR)/objects/contacts.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/notifications.cfg $(DESTDIR)$(CFGDIR)/objects/notifications.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/timeperiods.cfg $(DESTDIR)$(CFGDIR)/objects/timeperiods.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/localhost.cfg $(DESTDIR)$(CFGDIR)/objects/localhost.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/windows.cfg $(DESTDIR)$(CFGDIR)/objects/windows.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/printer.cfg $(DESTDIR)$(CFGDIR)/objects/printer.cfg
- $(INSTALL) -b -m 664 $(INSTALL_OPTS) sample-config/template-object/switch.cfg $(DESTDIR)$(CFGDIR)/objects/switch.cfg
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(CFGDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(CFGDIR)/objects
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(CFGDIR)/conf.d
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(CFGDIR)/modules
+ ${BSD_INSTALL_DATA} sample-config/icinga.cfg $(DESTDIR)$(CFGDIR)/icinga.cfg
+ ${BSD_INSTALL_DATA} sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/templates.cfg $(DESTDIR)$(CFGDIR)/objects/templates.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/commands.cfg $(DESTDIR)$(CFGDIR)/objects/commands.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/contacts.cfg $(DESTDIR)$(CFGDIR)/objects/contacts.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/notifications.cfg $(DESTDIR)$(CFGDIR)/objects/notifications.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/timeperiods.cfg $(DESTDIR)$(CFGDIR)/objects/timeperiods.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/localhost.cfg $(DESTDIR)$(CFGDIR)/objects/localhost.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/windows.cfg $(DESTDIR)$(CFGDIR)/objects/windows.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/printer.cfg $(DESTDIR)$(CFGDIR)/objects/printer.cfg
+ ${BSD_INSTALL_DATA} sample-config/template-object/switch.cfg $(DESTDIR)$(CFGDIR)/objects/switch.cfg
@echo ""
@echo "*** Config files installed ***"
@@ -457,14 +457,14 @@ install-config: install-cgiconf
@echo ""
install-testconfig:
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/tests
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(CFGDIR)/tests
for file in tests/etc/*.cfg; \
- do $(INSTALL) -b -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(CFGDIR)/tests; done
+ do ${BSD_INSTALL_DATA} $$file $(DESTDIR)$(CFGDIR)/tests; done
install-webconf:
- $(MKDIR) -p -m 775 $(DESTDIR)$(HTTPD_CONF)
- $(INSTALL) -b -m 644 $(INSTALL_OPTS) sample-config/httpd.conf $(DESTDIR)$(HTTPDCONFFILE)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(HTTPD_CONF)
+ ${BSD_INSTALL_DATA} sample-config/httpd.conf $(DESTDIR)$(HTTPDCONFFILE)
@echo ""
@echo "*** Icinga/Apache conf file installed ***"
@@ -472,7 +472,7 @@ install-webconf:
install-webconf-auth:
- $(INSTALL) -b -m 644 $(INSTALL_OPTS) icinga.htpasswd $(DESTDIR)$(HTTPAUTHFILE)
+ ${BSD_INSTALL_DATA} icinga.htpasswd $(DESTDIR)$(HTTPAUTHFILE)
@echo ""
@echo "*** Icinga http auth file installed ***"
@@ -508,11 +508,11 @@ install-idoutils:
install-init: install-daemoninit
install-daemoninit:
- $(INSTALL) -m 755 -d $(INIT_OPTS) $(DESTDIR)$(INIT_DIR)
- $(INSTALL) -m 755 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/icinga
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(INIT_DIR)
+ ${BSD_INSTALL_DATA} daemon-init $(DESTDIR)$(INIT_DIR)/icinga
@if [ x$(USE_IDOUTILS) = xyes ]; then \
- $(INSTALL) -m 755 $(INIT_OPTS) rc.ido2db $(DESTDIR)$(INIT_DIR)/ido2db ;\
+ ${BSD_INSTALL_SCRIPT} rc.ido2db $(DESTDIR)$(INIT_DIR)/ido2db ;\
fi
@echo ""
@@ -521,26 +521,26 @@ install-daemoninit:
install-commandmode:
- $(INSTALL) -m 775 $(COMMAND_OPTS) -d $(DESTDIR)$(EXTCMDFILEDIR)
- chmod g+s $(DESTDIR)$(EXTCMDFILEDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(EXTCMDFILEDIR)
+ #chmod g+s $(DESTDIR)$(EXTCMDFILEDIR)
@echo ""
@echo "*** External command directory configured ***"
@echo ""
install-eventhandlers:
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/submit_check_result $(DESTDIR)$(EVENTHANDLERDIR)/submit_check_result
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/disable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/disable_active_service_checks
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/enable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/enable_active_service_checks
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/disable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/disable_notifications
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/enable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/enable_notifications
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/distributed-monitoring/obsessive_svc_handler $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/obsessive_svc_handler
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/distributed-monitoring/submit_check_result_via_nsca $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/submit_check_result_via_nsca
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/redundancy-scenario1/handle-master-host-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-host-event
- $(INSTALL) -b -m 774 $(INSTALL_OPTS) contrib/eventhandlers/redundancy-scenario1/handle-master-proc-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-proc-event
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(EVENTHANDLERDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/submit_check_result $(DESTDIR)$(EVENTHANDLERDIR)/submit_check_result
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/disable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/disable_active_service_checks
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/enable_active_service_checks $(DESTDIR)$(EVENTHANDLERDIR)/enable_active_service_checks
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/disable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/disable_notifications
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/enable_notifications $(DESTDIR)$(EVENTHANDLERDIR)/enable_notifications
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/distributed-monitoring/obsessive_svc_handler $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/obsessive_svc_handler
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/distributed-monitoring/submit_check_result_via_nsca $(DESTDIR)$(EVENTHANDLERDIR)/distributed-monitoring/submit_check_result_via_nsca
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/redundancy-scenario1/handle-master-host-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-host-event
+ ${BSD_INSTALL_DATA} contrib/eventhandlers/redundancy-scenario1/handle-master-proc-event $(DESTDIR)$(EVENTHANDLERDIR)/redundancy-scenario1/handle-master-proc-event
@echo ""
@echo "*** Sample Eventhandlers installed ***"
@@ -550,10 +550,10 @@ install-eventhandlers:
install-classicui-standalone: install-cgis install-html install-cgiconf install-webconf
# make sure we keep all the needed dirs for data
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(STATEDIR)
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LOGDIR)/archives
- $(INSTALL) -m 775 $(COMMAND_OPTS) -d $(DESTDIR)$(EXTCMDFILEDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(STATEDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(LOGDIR)
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(LOGDIR)/archives
+ ${BSD_INSTALL_DATA_DIR} $(DESTDIR)$(EXTCMDFILEDIR)
@echo ""
@echo "*** Icinga Classic UI Standalone installed ***"
@@ -593,19 +593,19 @@ Prototype:
cd sample-config; \
for file in *.cfg; \
do \
- $(INSTALL) -m 644 $$file $(PACKDIR)/$(CFGDIR)/$$file.$(VERSION); \
+ ${BSD_INSTALL_DATA} $$file $(PACKDIR)/$(CFGDIR)/$$file.$(VERSION); \
done
chmod 640 $(PACKDIR)/$(CFGDIR)/resource.cfg.$(VERSION)
cd sample-config/template-object; \
for file in *.cfg; \
do \
- $(INSTALL) -m 644 $$file $(PACKDIR)/$(CFGDIR)/objects/$$file.$(VERSION); \
+ ${BSD_INSTALL_DATA} $$file $(PACKDIR)/$(CFGDIR)/objects/$$file.$(VERSION); \
done
mkdir -p $(PACKDIR)/lib/svc/method/
- $(INSTALL) -o root -g bin -m 555 daemon-init $(PACKDIR)/lib/svc/method/icinga
+ ${BSD_INSTALL_SCRIPT} daemon-init $(PACKDIR)/lib/svc/method/icinga
mkdir -p $(PACKDIR)/var/svc/manifest/application/
sed 's%!CFGPREFIX!%$(CFGDIR)%g' solaris/icinga.xml.tpl > solaris/icinga.xml
- $(INSTALL) -m 444 -o root -g root solaris/icinga.xml $(PACKDIR)/var/svc/manifest/application/
+ ${BSD_INSTALL_DATA} solaris/icinga.xml $(PACKDIR)/var/svc/manifest/application/
#cd contrib; $(MAKE) all; $(MAKE) DESTDIR=$(PACKDIR) INIT_OPTS='' INSTALL_OPTS='' COMMAND_OPTS='' icinga_grp='' icinga_usr='' install
echo i pkginfo > solaris/Prototype
if [ -f solaris/checkinstall.in ] ; then cat solaris/checkinstall.in | sed 's/!SUN_PLATFORM!/$(SUN_PLATFORM)/g' > solaris/checkinstall; fi