262e48de92
SFML is a free multimedia C++ API that provides you low and high level access to graphics, input, audio, etc. This package contains the C++ language bindings of SFML.
42 lines
1.8 KiB
Text
42 lines
1.8 KiB
Text
$NetBSD: patch-src_SFML_Window_CMakeLists.txt,v 1.1 2020/05/21 08:42:00 plunky Exp $
|
|
|
|
add NetBSD support
|
|
|
|
--- src/SFML/Window/CMakeLists.txt.orig 2018-10-15 19:41:39.000000000 +0000
|
|
+++ src/SFML/Window/CMakeLists.txt
|
|
@@ -79,7 +79,7 @@ if(SFML_OS_WINDOWS)
|
|
|
|
# make sure that we use the Unicode version of the Win API functions
|
|
add_definitions(-DUNICODE -D_UNICODE)
|
|
-elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_OPENBSD)
|
|
+elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OS_OPENBSD)
|
|
set(PLATFORM_SRC
|
|
${SRCROOT}/Unix/CursorImpl.hpp
|
|
${SRCROOT}/Unix/CursorImpl.cpp
|
|
@@ -110,7 +110,7 @@ elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD
|
|
${SRCROOT}/Unix/JoystickImpl.cpp
|
|
${SRCROOT}/Unix/JoystickImpl.hpp
|
|
)
|
|
- elseif(SFML_OS_FREEBSD)
|
|
+ elseif(SFML_OS_FREEBSD OR SFML_OS_NETBSD)
|
|
set(PLATFORM_SRC
|
|
${PLATFORM_SRC}
|
|
${SRCROOT}/FreeBSD/JoystickImpl.cpp
|
|
@@ -235,7 +235,7 @@ if ((NOT BUILD_SHARED_LIBS) AND SFML_OS_
|
|
endif()
|
|
|
|
# find and setup usage for external libraries
|
|
-if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OPENBSD)
|
|
+if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_NETBSD OR SFML_OPENBSD)
|
|
sfml_find_package(X11 INCLUDE "X11_INCLUDE_DIR" LINK "X11_X11_LIB" "X11_Xrandr_LIB")
|
|
target_link_libraries(sfml-window PRIVATE X11)
|
|
endif()
|
|
@@ -277,7 +277,7 @@ if(SFML_OS_LINUX)
|
|
target_link_libraries(sfml-window PRIVATE UDev)
|
|
elseif(SFML_OS_WINDOWS)
|
|
target_link_libraries(sfml-window PRIVATE winmm gdi32)
|
|
-elseif(SFML_OS_FREEBSD)
|
|
+elseif(SFML_OS_FREEBSD OR SFML_OS_NETBSD)
|
|
target_link_libraries(sfml-window PRIVATE usbhid)
|
|
elseif(SFML_OS_MACOSX)
|
|
target_link_libraries(sfml-window PRIVATE "-framework Foundation" "-framework AppKit" "-framework IOKit" "-framework Carbon")
|