e974d1d024
Based on the mozilla-5.0 branch. SeaMonkey 2.2 contains the following major changes relative to SeaMonkey 2.1: Windows: Bundled extensions/add-ons are no longer optional in SeaMonkey's installer. Archive options can now be changed from the Copies & Folders Account Settings pane. Mozilla platform changes CSS Animations are now supported. Improved canvas, JavaScript, memory, and networking performance. Improved standards support for HTML5, XHR, MathML, SMIL, and canvas. Improved spell checking for some locales. WebGL content can no longer load cross-domain textures. Background tabs have setTimeout and setInterval clamped to 1000ms to improve performance.
83 lines
2.6 KiB
Text
83 lines
2.6 KiB
Text
$NetBSD: patch-ac,v 1.7 2011/07/11 20:46:36 tnn Exp $
|
|
|
|
--- mozilla/nsprpub/configure.in.orig 2011-02-03 20:12:03.000000000 +0000
|
|
+++ mozilla/nsprpub/configure.in
|
|
@@ -71,7 +71,7 @@ OBJDIR_NAME=.
|
|
OBJDIR_SUFFIX=OBJ
|
|
NSINSTALL='$(MOD_DEPTH)/config/$(OBJDIR_NAME)/nsinstall'
|
|
NOSUCHFILE=/no-such-file
|
|
-LIBNSPR='-L$(dist_libdir) -lnspr$(MOD_MAJOR_VERSION)'
|
|
+LIBNSPR='-Wl,-R${prefix}/lib/${MOZILLA_PKG_NAME} -L$(dist_libdir) -lnspr$(MOD_MAJOR_VERSION)'
|
|
LIBPLC='-L$(dist_libdir) -lplc$(MOD_MAJOR_VERSION)'
|
|
CYGWIN_WRAPPER=
|
|
MACOS_SDK_DIR=
|
|
@@ -1311,6 +1311,34 @@ tools are selected during the Xcode/Deve
|
|
DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@)'
|
|
MDCPUCFG_H=_freebsd.cfg
|
|
PR_MD_CSRCS=freebsd.c
|
|
+ if test "$LIBRUNPATH"; then
|
|
+ DSO_LDOPTS="$DSO_LDOPTS -Wl,-R$LIBRUNPATH"
|
|
+ fi
|
|
+ ;;
|
|
+
|
|
+*-dragonfly*)
|
|
+ if test -z "$USE_NSPR_THREADS"; then
|
|
+ USE_PTHREADS=1
|
|
+ fi
|
|
+ AC_DEFINE(XP_UNIX)
|
|
+ AC_DEFINE(FREEBSD)
|
|
+ AC_DEFINE(HAVE_BSD_FLOCK)
|
|
+ AC_DEFINE(HAVE_SOCKLEN_T)
|
|
+ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
|
|
+ MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
|
|
+ if test "$MOZ_OBJFORMAT" = "elf"; then
|
|
+ DLL_SUFFIX=so
|
|
+ else
|
|
+ DLL_SUFFIX=so.1.0
|
|
+ fi
|
|
+ MKSHLIB='$(CC) $(DSO_LDOPTS) -o $@'
|
|
+ DSO_CFLAGS=-fPIC
|
|
+ DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@)'
|
|
+ MDCPUCFG_H=_freebsd.cfg
|
|
+ PR_MD_CSRCS=freebsd.c
|
|
+ if test "$LIBRUNPATH"; then
|
|
+ DSO_LDOPTS="$DSO_LDOPTS -Wl,-R$LIBRUNPATH"
|
|
+ fi
|
|
;;
|
|
|
|
*-hpux*)
|
|
@@ -1925,6 +1953,7 @@ mips-nec-sysv*)
|
|
AC_DEFINE(XP_UNIX)
|
|
AC_DEFINE(NETBSD)
|
|
AC_DEFINE(HAVE_BSD_FLOCK)
|
|
+ AC_DEFINE(HAVE_SOCKLEN_T)
|
|
if test -z "$USE_NSPR_THREADS"; then
|
|
USE_PTHREADS=1
|
|
fi
|
|
@@ -2730,7 +2759,7 @@ if test -n "$USE_PTHREADS"; then
|
|
if test -z "`egrep -i '(unrecognize|unknown)' conftest.out | grep pthread`" && test -z "`egrep -i '(error|incorrect)' conftest.out`" ; then
|
|
ac_cv_have_dash_pthread=yes
|
|
case "$target_os" in
|
|
- freebsd*)
|
|
+ freebsd* | dragonfly*)
|
|
# Freebsd doesn't use -pthread for compiles, it uses them for linking
|
|
;;
|
|
*)
|
|
@@ -2768,7 +2797,7 @@ if test -n "$USE_PTHREADS"; then
|
|
_PTHREAD_LDFLAGS=
|
|
fi
|
|
;;
|
|
- *-freebsd*)
|
|
+ *-freebsd* | *-dragonfly*)
|
|
AC_DEFINE(_REENTRANT)
|
|
AC_DEFINE(_THREAD_SAFE)
|
|
dnl -pthread links in -lc_r, so don't specify it explicitly.
|
|
@@ -2849,7 +2878,7 @@ case "$target" in
|
|
AC_DEFINE(_PR_NEED_PTHREAD_INIT)
|
|
fi
|
|
;;
|
|
-*-freebsd*)
|
|
+*-freebsd* | *-dragonfly*)
|
|
if test -n "$USE_NSPR_THREADS"; then
|
|
AC_DEFINE(_PR_LOCAL_THREADS_ONLY)
|
|
fi
|