pkgsrc/databases/cstore/patches/patch-ao
agc 9ea820f008 Initial import of cstore-0.2, a "column store" relational database,
into the Packages Collection. This package is meant to support data
warehousing in a much more efficient manner than traditional RDBMSs.

	C-Store is a read-optimized relational DBMS that contrasts sharply
	with most current systems, which are write-optimized.  Among the many
	differences in its design are:

	+ storage of data by column rather than by row,

	+ careful coding and packing of objects into storage including main
	memory during query processing,

	+ storing an overlapping collection of column-oriented projections,
	rather than the current fare of tables and indexes,

	+ a non-traditional implementation of transactions which includes high
	availability and snapshot isolation for read-only transactions,

	+ and the extensive use of bitmap indexes to complement B-tree
	structures.

Please note that the storage required for this package could be viewed
as being quite extreme - the standard build and data occupies in excess
of 20 GB, and that is all installed into ${PREFIX} at installation
time.
2007-11-10 11:33:00 +00:00

23 lines
688 B
Text

$NetBSD: patch-ao,v 1.1.1.1 2007/11/10 11:33:00 agc Exp $
--- Build/parser/subdir.mk 2007/11/08 10:39:53 1.1
+++ Build/parser/subdir.mk 2007/11/08 10:40:29
@@ -1,6 +1,6 @@
LEX = flex
LEXFLAGS = -i
-YACC = bison
+YACC = yacc
YACCFLAGS = -d
# intermediate things to be deleted if "make clean"
@@ -13,8 +13,8 @@
$(ROOT)/parser/grammar.cpp $(ROOT)/parser/grammar.h: $(ROOT)/parser/grammar.y
@echo 'Building: $@'
- $(YACC) $(YACCFLAGS) -o$@ $<
- mv $(ROOT)/parser/grammar.hpp $(ROOT)/parser/grammar.h
+ $(YACC) $(YACCFLAGS) -o $(ROOT)/parser/grammar.cpp $<
+ @echo > /dev/null mv $(ROOT)/parser/grammar.hpp $(ROOT)/parser/grammar.h
@echo 'Finished building: $<'
@echo ' '