pkgsrc/lang/guile14/patches/patch-ab
jlam ca70938428 Replace RPATH_FLAG with LINKER_RPATH_FLAG and COMPILER_RPATH_FLAG,
which are the full option names used to set rpath directives for the
linker and the compiler, respectively.  In places were we are invoking
the linker, use "${LINKER_RPATH_FLAG} <path>", where the space is
inserted in case the flag is a word, e.g. -rpath.  The default values
of *_RPATH_FLAG are set by the compiler/*.mk files, depending on the
compiler that you use.  They may be overridden on a ${OPSYS}-specific
basis by setting _OPSYS_LINKER_RPATH_FLAG and _OPSYS_COMPILER_RPATH_FLAG,
respectively.  Garbage-collect _OPSYS_RPATH_NAME and _COMPILER_LD_FLAG.
2004-08-27 06:29:06 +00:00

13 lines
470 B
Text

$NetBSD: patch-ab,v 1.2 2004/08/27 06:29:08 jlam Exp $
--- libguile/Makefile.in.orig 2004-04-28 20:56:11.000000000 -0700
+++ libguile/Makefile.in 2004-04-28 20:59:32.000000000 -0700
@@ -122,7 +122,7 @@ lib_LTLIBRARIES = libguile.la
bin_PROGRAMS = guile
guile_SOURCES = guile.c
-guile_LDADD = libguile.la ${THREAD_LIBS_LOCAL}
+guile_LDADD = libguile.la ${THREAD_LIBS_LOCAL} ${COMPILER_RPATH_FLAG}${PREFIX}/lib
guile_LDFLAGS = @DLPREOPEN@
libguile_la_SOURCES = \