pkgsrc/print/ghostscript/patches/patch-base_gdevpng.c
mef f10e57ba67 (1) Bump version 8.71 to 9.05 (importing from wip/ghostscript).
For the Changes: See
    share/ghostscript/9.05/doc/History9.htm
  Or
    work/ghostscript-9.05/doc/History9.htm
  Upstream releases and their date are:
        Version 9.05 (2012-02-08)
        Version 9.04 (2011-08-05)
        Version 9.02 (2011-03-30)
        Version 9.01 (2011-02-07)
        Version 9.00 (2010-09-14)

(2) Resolve pkg PR/44400.
options.mk:
  - Have new option disable-compile-inits
Makefile
  - rename cidfmap to cidfmap-dist (post-extract:)

(3) Have new file Makefile.common to share with
    fonts/ghostscript-cidfonts
    fonts/ghostscript-cidfonts-ryumin
  to set ${GS_VERSION}, and then ${GS_RESOURCEDIR}.

(4) options.mk
 - Add new options,
   disable-compile-inits
 - Add following line for non X11 installation
   CONFIGURE_ARGS+=       --disable-freetype
 - Name change
   pstorater.convs -> gstoraster.convs

(5) PLIST
  So many changes, but just a note:
  -share/ghostscript/${PKGVERSION}/doc/README
   share/ghostscript/${PKGVERSION}/doc/Readme.htm

(6)
patches directory:
Removed, for upstream included.
------
patch-aa   9.00	base/gsnogc.c
patch-ab   9.05	base/unixinst.mak
patch-ac   9.00	ase/gdevpx.c
patch-ad   9.04	lib/pv.sh
patch-ae   9.00	psi/zfile.c
patch-ag   9.00	cups/cups.mak

patch-ak   9.04	->  a part left in patch-base_gdevpng.c
patch-am   9.00	lib/pdf2dsc.ps

patch-ba   9.00	psi/idosave.h
patch-bb   9.00	psi/isave.c	(CVS-2010-1628)
patch-bc   9.00	psi/ialloc.c	(CVS-2010-1628)

patch-bd   9.00 (1) bug #691029 and #691108
           9.00 (2) arrayoption() macro
	   9.00 (3) silence compiler warning

Modified, or unchanged
------
patch-af  (Add comments from former commit log, and adjust)
patch-ah  (Add comments from former commit log, and adjust)
patch-ai  (Add comments from former commit log, and adjust)
patch-aj  (unchanged)
patch-al  (unchanged)
patch-an  (Add comments from former commit log, and adjust)

Added
--------
patch-base_gdevpng.c	(a part of previous patch-ak)
patch-base_gserrors_h	(silence compile warning)
patch-configure.ac	(For just a record, see patch-ah (configure))
patch-freetype_include_freetype_internal_t1types_h (To avoid redifintion of T1_EncodingType_ )
patch-openjpeg_libopenjpeg_opj_malloc_h (To avoid undefined ref. to memalign)

OK'ed by wiz@, thanks a lot.
2012-10-07 14:19:18 +00:00

25 lines
967 B
C

$NetBSD: patch-base_gdevpng.c,v 1.1 2012/10/07 14:19:18 mef Exp $
The patch was included in patches/patch-ak:
revision 1.5
date: 2011/01/15 14:08:10; author: wiz; state: Exp; lines: +194 -29
Fix build with png-1.5. Patch from John Bowler in private mail.
and 'fix for build with png-1.5' is now included in upstream in different
shape, so some left out is here:
--- base/gdevpng.c.orig 2011-08-05 20:12:20.000000000 +0900
+++ base/gdevpng.c 2011-08-22 19:04:12.000000000 +0900
@@ -40,8 +40,11 @@
/*
* libpng versions 1.0.3 and later allow disabling access to the stdxxx
* files while retaining support for FILE * I/O.
+ *
+ * This is a misunderstanding - this is a build time option for libpng,
+ * it has no effect on a user of libpng.
*/
-#define PNG_NO_CONSOLE_IO
+/*#define PNG_NO_CONSOLE_IO*/
/*
* Earlier libpng versions require disabling FILE * I/O altogether.
* This produces a compiler warning about no prototype for png_init_io.