pkgsrc/databases/postgresql14/patches/patch-src_Makefile.global.in
adam 5b84c8c22e postgresql14: added version 14.0
PostgreSQL 14 contains many new features and enhancements, including:

Stored procedures can now return data via OUT parameters.

The SQL-standard SEARCH and CYCLE options for common table expressions have been implemented.

Subscripting can now be applied to any data type for which it is a useful notation, not only arrays. In this release, the jsonb and hstore types have gained subscripting operators.

Range types have been extended by adding multiranges, allowing representation of noncontiguous data ranges.

Numerous performance improvements have been made for parallel queries, heavily-concurrent workloads, partitioned tables, logical replication, and vacuuming.

B-tree index updates are managed more efficiently, reducing index bloat.

VACUUM automatically becomes more aggressive, and skips inessential cleanup, if the database starts to approach a transaction ID wraparound condition.

Extended statistics can now be collected on expressions, allowing better planning results for complex queries.

libpq now has the ability to pipeline multiple queries, which can boost throughput over high-latency connections.
2021-10-08 10:23:43 +00:00

18 lines
447 B
Text

$NetBSD: patch-src_Makefile.global.in,v 1.1 2021/10/08 10:23:43 adam Exp $
Fix building on Cygwin.
--- src/Makefile.global.in.orig 2020-09-21 20:47:36.000000000 +0000
+++ src/Makefile.global.in
@@ -728,6 +728,11 @@ ifeq ($(PORTNAME),win32)
LIBS += -lws2_32
endif
+# missing for link on cygwin ?
+ifeq ($(PORTNAME),cygwin)
+LIBS += $(LDAP_LIBS_BE)
+endif
+
# Not really standard libc functions, used by the backend.
TAS = @TAS@