pkgsrc/editors/gummi/patches/patch-configure.ac
bsiegert d1b5c72788 Gummi 0.6.6 "We're still here" (January 27th, 2016):
Bugs fixed:

- Fix using predictable filenames in /tmp (CVE-2015-7758)
- Fix source id warnings during motion runtime
- Fix open-project crash due to missing file chooser title
- Fix synctex for input files with relative paths
- Add descriptive keywords to our desktop entry file
- Improvements to the bibliography detection regex
- Only allow loading tex files through file->open
- Desensitize cut/copy tools when no text is selected
- Various improvements to build system
- Removed deprecated code
2016-08-09 18:23:20 +00:00

16 lines
524 B
Text

$NetBSD: patch-configure.ac,v 1.1 2016/08/09 18:23:20 bsiegert Exp $
--- configure.ac.orig 2016-01-27 19:27:48.000000000 +0000
+++ configure.ac
@@ -65,7 +65,10 @@ if test "$spellcheck" = yes; then
fi
# Add explicit linking flags
-GUI_LIBS="$GUI_LIBS -pthread -lm -lz -lrt"
+GUI_LIBS="$GUI_LIBS -pthread -lm -lz"
+AC_CHECK_LIB(rt, clock_gettime, [
+ GUI_LIBS="$GUI_LIBS -lrt"
+])
# Checks for header files.
AC_CHECK_HEADERS([libintl.h locale.h netdb.h stdlib.h string.h sys/socket.h sys/time.h unistd.h fcntl.h])