pkgsrc/graphics/jpeg/patches/patch-af
wiz 00d30fb4e8 Update jpeg to 9b.
Comment two patches while here.

Version 9b  17-Jan-2016
-----------------------

Improvements and optimizations in DCT and color calculations.
Normalize range limit array composition and access pattern.
Thank to Sia Furler and Maddie Ziegler for inspiration.

Use merged upsample with scaled DCT sizes larger than 8.
Thank to Taylor Hatala for inspiration.

Check for excessive comment lengths in argument parsing in wrjpgcom.c.
Thank to Julian Cohen for hint.

Add makefile.b32 for use with Borland C++ 32-bit (bcc32).
Thank to Joe Slater for contribution.

Document 'f' specifier for jpegtran -crop specification.
Thank to Michele Martone for suggestion.

Use defined value from header instead of hardwired number in rdswitch.c.
Thank to Robert Sprowson for hint.
2016-02-01 09:22:53 +00:00

24 lines
751 B
Text

$NetBSD: patch-af,v 1.6 2016/02/01 09:22:53 wiz Exp $
Build and install jpegexiforient.
--- Makefile.am.orig 2012-05-09 13:13:36.000000000 +0000
+++ Makefile.am
@@ -76,7 +76,7 @@ if HAVE_LD_VERSION_SCRIPT
endif
# Executables to build
-bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom
+bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom jpegexiforient
# Executable sources & libs
cjpeg_SOURCES = cjpeg.c rdppm.c rdgif.c rdtarga.c rdrle.c rdbmp.c \
@@ -89,6 +89,8 @@ jpegtran_SOURCES = jpegtran.c rdswitch.c
jpegtran_LDADD = libjpeg.la
rdjpgcom_SOURCES = rdjpgcom.c
wrjpgcom_SOURCES = wrjpgcom.c
+jpegexiforient_SOURCES = jpegexiforient.c
+jpegexiforient_LDADD = libjpeg.la
# Manual pages to install
man_MANS = $(DISTMANS)