c166824a3b
----------------------------- History: (Changes,ChangeLog) 0.48 Jul09 fix buffer overflow introduced in 0.46 for filenames add codabar barcode fix bug, removing melted serifs add patch by Chris Lee, i25 barcode recognition + modifications fix some false positive numbers "34" (video, gas meter) fix problems with 2zZ4 for 10x10 screen font better debug output for :;,. remove examples, doc and libs part from configure (see below) remove doc and examples from the (make install) part to reduce dependencies (gs and transfig is not needed for rpm/ebuild) gocr only may depend from netpbm, but can live without too this will help to install gocr on "exotic" (nonlinux) platforms fix gentoo app-text/gocr Bug 243250 src/Makefile: $(CC) $(LDFLAGS) ...
24 lines
996 B
Text
24 lines
996 B
Text
$NetBSD: patch-ab,v 1.5 2016/07/24 23:59:55 mef Exp $
|
|
|
|
--- src/Makefile.in.orig 2009-04-09 18:06:53.000000000 +0900
|
|
+++ src/Makefile.in 2016-07-25 08:47:23.000000000 +0900
|
|
@@ -37,6 +37,8 @@ LIBOBJS=pgm2asc.o \
|
|
# these two lines are for cross-compiling, not tested
|
|
#srcdir = @srcdir@
|
|
#VPATH = @srcdir@
|
|
+prefix = @prefix@
|
|
+exec_prefix = @exec_prefix@
|
|
bindir = @bindir@
|
|
# lib removed for simplification
|
|
#libdir = @libdir@
|
|
@@ -101,10 +103,7 @@ $(LIBOBJS): Makefile
|
|
# PHONY = don't look at file clean, -rm = start rm and ignore errors
|
|
.PHONY : clean proper install uninstall
|
|
install: all
|
|
- #$(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
|
|
- $(INSTALL) -d $(DESTDIR)$(bindir)
|
|
$(INSTALL) ../bin/$(PROGRAM) $(DESTDIR)$(bindir)
|
|
- $(INSTALL) ../bin/gocr.tcl $(DESTDIR)$(bindir) # better X11/bin?
|
|
if test -f lib$(PGMASCLIB).a; then\
|
|
$(INSTALL) lib$(PGMASCLIB).a $(DESTDIR)$(libdir);\
|
|
$(INSTALL) lib$(PGMASCLIB).@PACKAGE_VERSION@.so $(DESTDIR)$(libdir);\
|