pkgsrc/databases/mysqlcc/patches/patch-ad
xtraeme dd87b9c51f * mysql_shutdown() takes two arguments in MySQL >= 4.1.3, fix this
checking MYSQL_VERSION_ID.
* Use mysql.bl3.mk and MYSQL_VERSIONS_ACCEPTED=40 41.

This fixes the bulk build problem, bump PKGREVISION.
2004-12-01 16:00:50 +00:00

16 lines
436 B
Text

$NetBSD: patch-ad,v 1.1 2004/12/01 16:00:50 xtraeme Exp $
--- shared/src/CMySQL.cpp.orig 2004-12-01 16:35:54.000000000 +0100
+++ shared/src/CMySQL.cpp 2004-12-01 16:37:29.000000000 +0100
@@ -451,7 +451,11 @@
if (!isConnected())
return false;
+#if (MYSQL_VERSION_ID >= 40103)
+ if (mysql_shutdown(mysql, SHUTDOWN_DEFAULT) != 0)
+#else
if (mysql_shutdown(mysql) != 0)
+#endif
{
if (emiterror)
emitError();