eedf710115
Fixes build with OpenSSL-1.1. libgda 5.2.9 - Fix Sun JRE 1.8 detection - Fix JDK 11.0 detection - Drop unneeded JAVAH variable check - Fix build for System Installed SQLite libs - Non-Dates and Timestamps values returns 'NULL' string when converted - Fix --with-ui, now UI is buildable when enable libgda 5.2.8 2018-12-03 - Fix a typo on sv translation - Please note: releases 5.2.6 and 5.2.7 were unable to be published at downdload.gnome.org libgda 5.2.7 2018-11-07 - SQLite provider uses system installed one by default - Revome build's date from documentation - introspection: removed system install in favor of --prefix libgda 5.2.6 2018-10-03 - Fixed compilation on MacOS - All Vala bindings and Vala extensions are built by default using --enable-vala, added --disable* switch to disable some or all of them - Fixes on outdated unit tests - Removed unused Vala extensions - Translations: - es (Daniel Mustieles) libgda 5.2.5 2018-09-25 - GdaConnection has removed the use of g_object_weak_*, improving multi-threading behaviour - Prepared statements now use GWeakRef for weak references - GdaDataPivot use instance providers and locking - GdaVConnectionDataModel use GRecMutex - Updated SQLite to 3.8.11.1 - Fix SQLCipher build by embedding source code for 3.4.2 version - Fix SQLCipher disabling - Updated GObject Introspection annotations - Fix Doc generation - Bugs corrected: #787685 #789382 #761560 #761529 #760420 #761424 #754263 #754208 - Corrected HTML output containing <SCRIPT> tag - Correct some truncated help strings - Don't use (deprecated) g_thread_supported() - MySQL meta data: fixed case where schema is incomplete in MySQL database - Allow introspection for gda_sql_builder_add_cond_v() - SQLite: handle WITHOUT ROWID without any error - Translations: - es (Daniel Mustieles) - da (Ask Hjorth Larsen) - pt_BR (Rafael Fontenelle) - eu (Inaki Larranaga Murgoitio) - sr (Мирослав Николић) - sv (Anders Jonsson) - de (Mario Blättermann) - cs (Marek Černocký) - hu (Balázs Meskó) - oc (Balázs Meskó) - el (Tom Tryfonidis) - po (Pedro Albuquerque) - id (Andika Triwidada) libgda 5.2.4, 2015-06-13 - Added missing file in distributed tarball, bug #750891 libgda 5.2.3, 2015-06-12 - Improved Vala and introspection - Bugs corrected: #722531, #722773, #730813, #742312, #750191 and others - Translations: - zh_CN (Wylmer Wang) - el (Dimitris Spingos) - sr (Мирослав Николић) - bs (Samir Ribic) - pl (Piotr Drąg) - cs (Marek Černocký) - es (Daniel Mustieles) - id (Andika Triwidada) - eu (Inaki Larranaga Murgoitio) - pt (Pedro Albuquerque)
24 lines
1,005 B
Text
24 lines
1,005 B
Text
$NetBSD: patch-providers_mysql_Makefile.in,v 1.2 2019/05/17 08:20:34 wiz Exp $
|
|
|
|
For building mysql plugin as a separate package.
|
|
|
|
--- providers/mysql/Makefile.in.orig 2013-10-02 11:34:25.000000000 +0000
|
|
+++ providers/mysql/Makefile.in
|
|
@@ -99,7 +99,7 @@ am__installdirs = "$(DESTDIR)$(providerd
|
|
"$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(xmldir)"
|
|
LTLIBRARIES = $(provider_LTLIBRARIES)
|
|
am__DEPENDENCIES_1 =
|
|
-libgda_mysql_la_DEPENDENCIES = $(top_builddir)/libgda/libgda-5.0.la \
|
|
+libgda_mysql_la_DEPENDENCIES = \
|
|
$(top_builddir)/providers/reuseable/mysql/libgda-mysql.la \
|
|
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
|
|
am__objects_1 = gda-mysql-handler-bin.lo
|
|
@@ -467,7 +467,7 @@ libgda_mysql_la_SOURCES = \
|
|
|
|
libgda_mysql_la_LDFLAGS = -export-dynamic -module -avoid-version $(NO_UNDEFINED) $(LIBTOOL_PROV_EXPORT_OPTIONS)
|
|
libgda_mysql_la_LIBADD = \
|
|
- $(top_builddir)/libgda/libgda-5.0.la \
|
|
+ -lgda-5.0 \
|
|
$(top_builddir)/providers/reuseable/mysql/libgda-mysql.la \
|
|
$(COREDEPS_LIBS) $(MYSQL_LIBS)
|
|
|