pkgsrc/net/pppd/patches/patch-ab
cube 3e86158156 Initial import of pppd, version 2.4.3, into the NetBSD Package Collection.
The PPP Daemon is the userland part of the Point-to-Point Protocol.  It works
in combination with a dedicated kernel network interface usually named ppp.
PPP is a very extensible protocol and pppd supports a large number of options,
including compression (through various algorithms), cryptography (Microsoft's
MPPE) and authentication (PAP, CHAP, Microsoft CHAP), provided the kernel has
the relevant back-ends in some cases.
2005-01-02 02:51:40 +00:00

34 lines
748 B
Text

$NetBSD: patch-ab,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
--- chat/Makefile.netbsd.orig 2004-12-31 23:50:59.000000000 +0100
+++ chat/Makefile.netbsd
@@ -0,0 +1,29 @@
+DESTDIR = @DESTDIR@
+BINDIR = $(DESTDIR)/sbin
+MANDIR = $(DESTDIR)/man/man8
+
+CDEF1= -DTERMIOS # Use the termios structure
+CDEF2= -DSIGTYPE=void # Standard definition
+CDEF3= -DHAS_STRLFUNCS # strlcat and strlcpy
+CDEFS= $(CDEF1) $(CDEF2) $(CDEF3)
+
+COPTS= -O2 -g -pipe
+CFLAGS= $(COPTS) $(CDEFS)
+
+INSTALL= install
+
+all: chat
+
+chat: chat.o
+ $(CC) -o chat chat.o
+
+chat.o: chat.c
+ $(CC) -c $(CFLAGS) -o chat.o chat.c
+
+install: chat
+ mkdir -p $(BINDIR)
+ $(INSTALL) -s -c chat $(BINDIR)
+ $(INSTALL) -c -m 644 chat.8 $(MANDIR)
+
+clean:
+ rm -f chat.o chat *~