pkgsrc/net/pppd/patches/patch-bl
cube 3e86158156 Initial import of pppd, version 2.4.3, into the NetBSD Package Collection.
The PPP Daemon is the userland part of the Point-to-Point Protocol.  It works
in combination with a dedicated kernel network interface usually named ppp.
PPP is a very extensible protocol and pppd supports a large number of options,
including compression (through various algorithms), cryptography (Microsoft's
MPPE) and authentication (PAP, CHAP, Microsoft CHAP), provided the kernel has
the relevant back-ends in some cases.
2005-01-02 02:51:40 +00:00

40 lines
805 B
Text

$NetBSD: patch-bl,v 1.1.1.1 2005/01/02 02:51:44 cube Exp $
--- pppstats/Makefile.netbsd.orig 2004-12-31 23:51:00.000000000 +0100
+++ pppstats/Makefile.netbsd
@@ -0,0 +1,35 @@
+#
+# pppstats makefile
+#
+DESTDIR = @DESTDIR@
+BINDIR = $(DESTDIR)/sbin
+MANDIR = $(DESTDIR)/man/man8
+
+PPPSTATSRCS = pppstats.c
+PPPSTATOBJS = pppstats.o
+
+#CC = gcc
+COPTS = -O
+COMPILE_FLAGS = -I../include
+LIBS =
+
+INSTALL= install
+
+CFLAGS = $(COPTS) $(COMPILE_FLAGS)
+
+all: pppstats
+
+install: pppstats
+ -mkdir -p $(MANDIR)
+ $(INSTALL) -s -c pppstats $(BINDIR)
+ $(INSTALL) -c -m 444 pppstats.8 $(MANDIR)
+
+pppstats: $(PPPSTATSRCS)
+ $(CC) $(CFLAGS) -o pppstats pppstats.c $(LIBS)
+
+clean:
+ rm -f pppstats *~ #* core
+
+depend:
+ cpp -M $(CFLAGS) $(PPPSTATSRCS) >.depend
+# makedepend $(CFLAGS) $(PPPSTATSRCS)