aac46ee0fd
This version is a response to the "clamav 0.65 remote DOS exploit" information published on popular security-related mailing lists. Other changes include: (see the README for a full list) -) clamd: + fixed database timestamp handling (and a double reload problem reported by Alex Pleiner and Ole Stanstrup) + new directive: ArchiveMaxCompressionRatio + new command: SESSION (starts a clamd session and allows to do multiple commands per TCP session) + new directives: TemporaryDirectory, LogClean (Andrey V. Malyshev) -) freshclam: + support for freshclam.conf (that may be optionally merged with clamav.conf, command line options overwrite config settings) + work-around for potential database downgrade (subtle problem in r-r dns handling) - reported by Daniel Mario Vega and patched by Luca Gibelli Fix build by rather patch "configure" directly instead of configure.in (autoconf failed). Tested on NetBSD-current and Linux (some kind of Debian).
61 lines
1.4 KiB
Text
61 lines
1.4 KiB
Text
$NetBSD: patch-aa,v 1.7 2004/02/11 10:55:49 recht Exp $
|
|
|
|
--- configure.orig 2004-02-11 00:16:08.000000000 +0100
|
|
+++ configure 2004-02-11 11:34:05.000000000 +0100
|
|
@@ -8773,7 +8773,17 @@
|
|
fi
|
|
|
|
|
|
-have_milter="no"
|
|
+# Check whether --enable-milter or --disable-milter was given.
|
|
+if test "${enable_milter+set}" = set; then
|
|
+ enableval="$enable_milter"
|
|
+
|
|
+else
|
|
+ have_milter="no"
|
|
+ want_milter="no"
|
|
+fi;
|
|
+
|
|
+if test "$want_milter" = "yes"
|
|
+then
|
|
if test "${ac_cv_header_libmilter_mfapi_h+set}" = set; then
|
|
echo "$as_me:$LINENO: checking for libmilter/mfapi.h" >&5
|
|
echo $ECHO_N "checking for libmilter/mfapi.h... $ECHO_C" >&6
|
|
@@ -8879,15 +8889,7 @@
|
|
have_milter="yes"
|
|
fi
|
|
|
|
-
|
|
-
|
|
-# Check whether --enable-milter or --disable-milter was given.
|
|
-if test "${enable_milter+set}" = set; then
|
|
- enableval="$enable_milter"
|
|
-
|
|
-else
|
|
- have_milter="no"
|
|
-fi;
|
|
+fi
|
|
|
|
want_dsig="yes"
|
|
# Check whether --enable-dsig or --disable-dsig was given.
|
|
@@ -9502,11 +9504,17 @@
|
|
|
|
;;
|
|
netbsd*)
|
|
- echo "$as_me:$LINENO: result: NetBSD detected. Disabling thread support." >&5
|
|
-echo "${ECHO_T}NetBSD detected. Disabling thread support." >&6
|
|
- have_pthreads="no"
|
|
+ if test "$have_pthreads" = "yes"; then
|
|
+ LIBCLAMAV_LIBS="$LIBCLAMAV_LIBS -lpthread"
|
|
+ CLAMD_LIBS="-lpthread"
|
|
+ TH_SAFE="-thread-safe"
|
|
|
|
cat >>confdefs.h <<\_ACEOF
|
|
+#define CL_THREAD_SAFE 1
|
|
+_ACEOF
|
|
+
|
|
+ fi
|
|
+cat >>confdefs.h <<\_ACEOF
|
|
#define C_BSD 1
|
|
_ACEOF
|
|
|