pkgsrc/x11/xpns/patches/patch-steio_c
dholland bfa9b7b376 Fix wrong hard-wired paths in patch-ab. (was using /usr/X11R6)
While here:
  - sprinkle stdlib.h widely to avoid undefined behavior calling malloc
  - fix randomizer setup (was calling srand() and then using random())
  - avoid installing a csh script, since we were replacing the entire
    contents of the file anyhow
  - add missing libXt and libX11 bl3.mk
  - add patch comments

PKGREVISION -> 4.
2012-06-16 04:00:53 +00:00

14 lines
298 B
Text

$NetBSD: patch-steio_c,v 1.1 2012/06/16 04:00:54 dholland Exp $
Ues standard headers.
--- steio.c~ 1993-07-14 11:02:15.000000000 +0000
+++ steio.c
@@ -15,6 +15,7 @@
#include "celltype.h"
#include "netsize.h"
#include <stdio.h>
+#include <stdlib.h>
#define DEFAULT_STEN_X_DISP -HA_STE_RAD