pkgsrc/x11/kdelibs3/patches/patch-bn
markd 528e056cde Update KDE to 3.1.
Many bugfixes and functionality enhancements including:

General

 New default widget style: Keramik
 New default icon theme: Crystal

 Created and enhanced framework to effectively disable certain features of
 the GUI, like for example shell access, disallowing to select custom wall
 papers. "Kiosk mode"
 Usability improvements:
   Kicker: Context menu, applet menus, wording and panel feature consistency
   improved
   Kicker: Redesigned control module.
   KCalc: Usability Improvements.
   KSnapshot: Usability Improvements.
   KsCD: User Interface Improvements in configuration and information dialogs


kdelibs

 Extended the DCOP commandline client to
   enable nonGUI applications (such as shell scripts) to use DCOP
   send DCOP messages to multiple users and/or sessions concurrently
 Added to notification dialog to allow applications to configure their
 notifications with a common GUI.
 Added "Open File", "Open Destination" and "Keep window open" to download
 progress dialog.
 KDatePicker has now week number display and selection.
 Added KLocale support for setting/retrieving the first day of a week
 Support for "Multimedia keys" on your keyboard.
 Added on-demand icon loading support to improve startup performance of
 applications.
 KHTML:
   Improvements to printing support.
   Page Info and Frame info dialog.
   Auto-Scroll support of webpages using Shift combined with arrow keys.
   Many, many Bugfixes and improvements.
   Small codebase merges with Safari. The main merge is planned for a future
   release however, as it requires more testing.
 KIO:
   Modified thumbnail ioslave that can extract a thumbnail from the file
   directly if it contains one, rather than generating one itself.
   Added fish:// protocol slave, which can access remote filesystems via
   SSH and SCP
   Cleanups and Corrections in smtp:// protocol slave.
   Activated rtsp:// protocol slave.
   Added support for Public Key Authentication and interopability with newer
   versions of OpenSSH to sftp:// protocol slave.
 KSSL:
   SSL certificate policies can now be configured based on the host name
2003-03-11 13:10:15 +00:00

161 lines
7.6 KiB
Text

$NetBSD: patch-bn,v 1.5 2003/03/11 13:10:38 markd Exp $
--- kioslave/http/Makefile.in.orig Thu Jan 23 12:30:40 2003
+++ kioslave/http/Makefile.in
@@ -293,7 +293,7 @@
####### Files
bin_PROGRAMS = kio_http_cache_cleaner
-lib_LTLIBRARIES = kio_http_cache_cleaner.la
+lib_LTLIBRARIES = libkio_http_cache_cleaner_main.la kio_http_cache_cleaner.la
kde_module_LTLIBRARIES = kio_http.la
kio_http_la_SOURCES = http.cc httpfilter.cc
@@ -301,12 +301,15 @@
kio_http_la_LIBADD = $(LIB_KIO) $(LIBZ)
kio_http_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
-kio_http_cache_cleaner_SOURCES = dummy.cpp
-kio_http_cache_cleaner_LDADD = kio_http_cache_cleaner.la
+kio_http_cache_cleaner_SOURCES = http_cache_cleaner_main.cpp
+kio_http_cache_cleaner_LDADD = libkio_http_cache_cleaner_main.la
kio_http_cache_cleaner_LDFLAGS = $(KDE_RPATH)
-kio_http_cache_cleaner_la_SOURCES = http_cache_cleaner.cpp
-kio_http_cache_cleaner_la_LIBADD = $(LIB_KIO)
+libkio_http_cache_cleaner_main_la_SOURCES = http_cache_cleaner.cpp
+libkio_http_cache_cleaner_main_la_LIBADD = $(LIB_KIO)
+
+kio_http_cache_cleaner_la_SOURCES = http_cache_cleaner_main.cpp
+kio_http_cache_cleaner_la_LIBADD = libkio_http_cache_cleaner_main.la
kio_http_cache_cleaner_la_LDFLAGS = -module -avoid-version
noinst_HEADERS = http.h
@@ -329,20 +332,28 @@
kio_http_la_nofinal_OBJECTS = http.lo httpfilter.lo
@KDE_USE_FINAL_FALSE@kio_http_la_OBJECTS = $(kio_http_la_nofinal_OBJECTS)
@KDE_USE_FINAL_TRUE@kio_http_la_OBJECTS = $(kio_http_la_final_OBJECTS)
-kio_http_cache_cleaner_la_DEPENDENCIES =
-am_kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner.lo
+kio_http_cache_cleaner_la_DEPENDENCIES = \
+ libkio_http_cache_cleaner_main.la
+am_kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner_main.lo
#>- kio_http_cache_cleaner_la_OBJECTS = \
#>- $(am_kio_http_cache_cleaner_la_OBJECTS)
#>+ 1
-kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner.lo
+kio_http_cache_cleaner_la_OBJECTS = http_cache_cleaner_main.lo
+libkio_http_cache_cleaner_main_la_LDFLAGS =
+libkio_http_cache_cleaner_main_la_DEPENDENCIES =
+am_libkio_http_cache_cleaner_main_la_OBJECTS = http_cache_cleaner.lo
+#>- libkio_http_cache_cleaner_main_la_OBJECTS = \
+#>- $(am_libkio_http_cache_cleaner_main_la_OBJECTS)
+#>+ 1
+libkio_http_cache_cleaner_main_la_OBJECTS = http_cache_cleaner.lo
bin_PROGRAMS = kio_http_cache_cleaner$(EXEEXT)
PROGRAMS = $(bin_PROGRAMS)
-am_kio_http_cache_cleaner_OBJECTS = dummy.$(OBJEXT)
+am_kio_http_cache_cleaner_OBJECTS = http_cache_cleaner_main.$(OBJEXT)
#>- kio_http_cache_cleaner_OBJECTS = $(am_kio_http_cache_cleaner_OBJECTS)
#>+ 1
-kio_http_cache_cleaner_OBJECTS = dummy.$(OBJEXT)
-kio_http_cache_cleaner_DEPENDENCIES = kio_http_cache_cleaner.la
+kio_http_cache_cleaner_OBJECTS = http_cache_cleaner_main.$(OBJEXT)
+kio_http_cache_cleaner_DEPENDENCIES = libkio_http_cache_cleaner_main.la
DEFS = @DEFS@
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
@@ -350,15 +361,21 @@
LIBS = @LIBS@
depcomp = $(SHELL) $(top_srcdir)/admin/depcomp
am__depfiles_maybe = depfiles
-#>- @AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/dummy.Po ./$(DEPDIR)/http.Plo \
+#>- @AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/http.Plo \
#>- @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner.Plo \
+#>- @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner_main.Plo \
+#>- @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner_main.Po \
#>- @AMDEP_TRUE@ ./$(DEPDIR)/httpfilter.Plo
-#>+ 7
-@AMDEP_TRUE@@KDE_USE_FINAL_TRUE@DEP_FILES = $(DEPDIR)/kio_http_la.all_cc.P ./$(DEPDIR)/dummy.Po ./$(DEPDIR)/http.Plo \
+#>+ 11
+@AMDEP_TRUE@@KDE_USE_FINAL_TRUE@DEP_FILES = $(DEPDIR)/kio_http_la.all_cc.P ./$(DEPDIR)/http.Plo \
@AMDEP_TRUE@@KDE_USE_FINAL_TRUE@ @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner.Plo \
+@AMDEP_TRUE@@KDE_USE_FINAL_TRUE@ @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner_main.Plo \
+@AMDEP_TRUE@@KDE_USE_FINAL_TRUE@ @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner_main.Po \
@AMDEP_TRUE@@KDE_USE_FINAL_TRUE@ @AMDEP_TRUE@ ./$(DEPDIR)/httpfilter.Plo
-@AMDEP_TRUE@@KDE_USE_FINAL_FALSE@DEP_FILES = ./$(DEPDIR)/dummy.Po ./$(DEPDIR)/http.Plo \
+@AMDEP_TRUE@@KDE_USE_FINAL_FALSE@DEP_FILES = ./$(DEPDIR)/http.Plo \
@AMDEP_TRUE@@KDE_USE_FINAL_FALSE@ @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner.Plo \
+@AMDEP_TRUE@@KDE_USE_FINAL_FALSE@ @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner_main.Plo \
+@AMDEP_TRUE@@KDE_USE_FINAL_FALSE@ @AMDEP_TRUE@ ./$(DEPDIR)/http_cache_cleaner_main.Po \
@AMDEP_TRUE@@KDE_USE_FINAL_FALSE@ @AMDEP_TRUE@ ./$(DEPDIR)/httpfilter.Plo
#>- CXXCOMPILE = $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
@@ -390,6 +407,7 @@
$(AM_LDFLAGS) $(LDFLAGS) -o $@
DIST_SOURCES = $(kio_http_la_SOURCES) \
$(kio_http_cache_cleaner_la_SOURCES) \
+ $(libkio_http_cache_cleaner_main_la_SOURCES) \
$(kio_http_cache_cleaner_SOURCES)
DATA = $(kdelnk_DATA)
@@ -402,7 +420,7 @@
uninstall-recursive check-recursive installcheck-recursive
DIST_COMMON = $(noinst_HEADERS) Makefile.am Makefile.in TODO
DIST_SUBDIRS = $(SUBDIRS)
-SOURCES = $(kio_http_la_SOURCES) $(kio_http_cache_cleaner_la_SOURCES) $(kio_http_cache_cleaner_SOURCES)
+SOURCES = $(kio_http_la_SOURCES) $(kio_http_cache_cleaner_la_SOURCES) $(libkio_http_cache_cleaner_main_la_SOURCES) $(kio_http_cache_cleaner_SOURCES)
#>- all: all-recursive
#>+ 1
@@ -482,6 +500,8 @@
$(CXXLINK) -rpath $(kde_moduledir) $(kio_http_la_LDFLAGS) $(kio_http_la_OBJECTS) $(kio_http_la_LIBADD) $(LIBS)
kio_http_cache_cleaner.la: $(kio_http_cache_cleaner_la_OBJECTS) $(kio_http_cache_cleaner_la_DEPENDENCIES)
$(CXXLINK) -rpath $(libdir) $(kio_http_cache_cleaner_la_LDFLAGS) $(kio_http_cache_cleaner_la_OBJECTS) $(kio_http_cache_cleaner_la_LIBADD) $(LIBS)
+libkio_http_cache_cleaner_main.la: $(libkio_http_cache_cleaner_main_la_OBJECTS) $(libkio_http_cache_cleaner_main_la_DEPENDENCIES)
+ $(CXXLINK) -rpath $(libdir) $(libkio_http_cache_cleaner_main_la_LDFLAGS) $(libkio_http_cache_cleaner_main_la_OBJECTS) $(libkio_http_cache_cleaner_main_la_LIBADD) $(LIBS)
binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
install-binPROGRAMS: $(bin_PROGRAMS)
@$(NORMAL_INSTALL)
@@ -521,9 +541,10 @@
distclean-compile:
-rm -f *.tab.c
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/dummy.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/http.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/http_cache_cleaner.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/http_cache_cleaner_main.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/http_cache_cleaner_main.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/httpfilter.Plo@am__quote@
distclean-depend:
@@ -691,7 +712,7 @@
-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH
#>- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
#>+ 4
-KDE_DIST=webdav.protocol http_cache_cleaner.desktop README.webdav rfc2817.txt THOUGHTS README.http_cache_cleaner webdavs.protocol rfc2617.txt rfc2818.txt rfc2616.txt http.protocol https.protocol httpfilter.h rfc3253.txt rfc2518.txt
+KDE_DIST=README.http_cache_cleaner http_cache_cleaner.desktop rfc2817.txt httpfilter.h webdavs.protocol rfc3253.txt rfc2818.txt http.protocol webdav.protocol README.webdav https.protocol rfc2616.txt rfc2518.txt rfc2617.txt THOUGHTS
DISTFILES= $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)
@@ -840,9 +861,6 @@
uninstall-kdelnkDATA uninstall-libLTLIBRARIES \
uninstall-recursive
-
-dummy.cpp:
- echo > dummy.cpp
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
@@ -919,7 +937,7 @@
-rm -f *.rpo
#>+ 5
+http.o: http.moc
+httpfilter.lo: httpfilter.moc
httpfilter.o: httpfilter.moc
http.lo: http.moc
-httpfilter.lo: httpfilter.moc
-http.o: http.moc