pkgsrc/mail/thunderbird/files/patch-ipc_src_Makefile
ryoon 78782af087 Update to 31.0
* Update enigmail to 1.7

Changelog:
    NEW
    Autocompleting email addresses now matches against any part of the name or email (bug 529584)

    NEW
    Composing a mail to a newsgroup will now autocomplete newsgroup names (bug 61491)

    FIXED
    Insecure NTLM (pre-NTLMv2) authentication disabled (see 828183)

Fixed in Thunderbird 31
MFSA 2014-66 IFRAME sandbox same-origin access through redirect
MFSA 2014-65 Certificate parsing broken by non-standard character encoding
MFSA 2014-64 Crash in Skia library when scaling high quality images
MFSA 2014-63 Use-after-free while when manipulating certificates in the trusted cache
MFSA 2014-62 Exploitable WebGL crash with Cesium JavaScript library
MFSA 2014-61 Use-after-free with FireOnStateChange event
MFSA 2014-59 Use-after-free in DirectWrite font handling
MFSA 2014-58 Use-after-free in Web Audio due to incorrect control message ordering
MFSA 2014-57 Buffer overflow during Web Audio buffering for playback
MFSA 2014-56 Miscellaneous memory safety hazards (rv:31.0 / rv:24.7)
2014-07-27 20:04:59 +00:00

16 lines
399 B
Text

diff --git a/ipc/src/Makefile b/ipc/src/Makefile
index 4546c3e..2e0998d 100644
--- a/ipc/src/Makefile
+++ b/ipc/src/Makefile
@@ -49,6 +49,11 @@ ifeq ($(OS_TARGET),WINNT)
OBJ_SUFF = obj
endif
+ifeq ($(OS_ARCH),SunOS)
+LDFLAGS += -shared -Wl,-Bsymbolic
+CFLAGS += -fPIC
+endif
+
source = subprocess.c
objfiles = subprocess.$(OBJ_SUFF)
libname = $(DLL_PREFIX)subprocess-$(CPU_ARCH)$(DLL_SUFFIX)