dce65f72d2
The following things have been changed compared to version 1.12: o Corrected German message catalog o Changes to English diction file o Fixed ellipsis handling
56 lines
1.9 KiB
Text
56 lines
1.9 KiB
Text
$NetBSD: patch-aa,v 1.3 2015/01/16 11:49:07 wiz Exp $
|
|
|
|
--- Makefile.in.orig 2011-08-31 17:04:19.000000000 +0000
|
|
+++ Makefile.in
|
|
@@ -18,7 +18,7 @@ CFLAGS= @CFLAGS@
|
|
CPPFLAGS= @CPPFLAGS@ -I. -DSHAREDIR=\"@datarootdir@\" -DLOCALEDIR=\"$(localedir)\"
|
|
LDFLAGS= @LDFLAGS@
|
|
LIBM= -lm
|
|
-LIBS= @LIBS@
|
|
+LIBS= @LIBS@ ${LIBPCREPOSIX}
|
|
|
|
CATALOGS= de.mo en_GB.mo nl.mo
|
|
|
|
@@ -26,13 +26,13 @@ all: diction style all-po-@USE_NLS@
|
|
all-po-no:
|
|
all-po-yes: $(CATALOGS)
|
|
|
|
-diction: diction.o sentence.o misc.o getopt.o getopt1.o
|
|
- $(CC) -o $@ $(LDFLAGS) diction.o sentence.o misc.o \
|
|
- getopt.o getopt1.o $(LIBS)
|
|
-
|
|
-style: style.o sentence.o misc.o getopt.o getopt1.o
|
|
- $(CC) -o $@ $(LDFLAGS) style.o sentence.o misc.o \
|
|
- getopt.o getopt1.o $(LIBM) $(LIBS)
|
|
+diction: diction.o sentence.o misc.o
|
|
+ ${LIBTOOL} --mode=link --tag=CC $(CC) -o $@ $(LDFLAGS) \
|
|
+ diction.lo sentence.lo misc.lo $(LIBS)
|
|
+
|
|
+style: style.o sentence.o misc.o
|
|
+ ${LIBTOOL} --mode=link --tag=CC $(CC) -o $@ $(LDFLAGS) \
|
|
+ style.lo sentence.lo misc.lo $(LIBM) $(LIBS)
|
|
|
|
check: diction
|
|
for i in $(srcdir)/test/test*; do $$i || break; done
|
|
@@ -61,7 +61,7 @@ install-po-yes: $(CATALOGS)
|
|
done
|
|
|
|
.c.o:
|
|
- $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
|
|
+ ${LIBTOOL} --mode=compile --tag=CC $(CC) -c $(CPPFLAGS) $(CFLAGS) -prefer-pic $<
|
|
|
|
.SUFFIXES: .po .mo
|
|
|
|
@@ -110,10 +110,8 @@ tar: distclean
|
|
(b=`pwd`; b=`basename $$b`; cd ..; tar zcvf $$b.tar.gz $$b/COPYING $$b/INSTALL $$b/Makefile.in $$b/README $$b/NEWS $$b/configure $$b/install-sh $$b/de $$b/en $$b/en_GB $$b/nl $$b/test $$b/[a-z]*.*)
|
|
#}}}
|
|
#{{{ dependencies
|
|
-diction.o: diction.c config.h getopt.h misc.h sentence.h
|
|
-getopt.o: getopt.c getopt.h getopt_int.h
|
|
-getopt1.o: getopt1.c getopt.h getopt_int.h
|
|
+diction.o: diction.c config.h misc.h sentence.h
|
|
misc.o: misc.c config.h misc.h
|
|
sentence.o: sentence.c config.h misc.h sentence.h
|
|
-style.o: style.c config.h getopt.h misc.h sentence.h
|
|
+style.o: style.c config.h misc.h sentence.h
|
|
#}}}
|