pkgsrc/sysutils/xenkernel411/patches/patch-xen_arch_x86_Rules.mk
bouyer 635c6af9fc Add Xen 4.11.0 packages.
Note that there is a bug in 4.11 (also present in recent 4.6 and 4.8)
which causes an infrequent assert failure when running NetBSD PV guests.
The root cause has not been found, but a workaround is inclued which doesn't
seems to have ill effects. See xenkernel411/patches/patch-zz-bouyer
for details.
2018-07-24 13:40:11 +00:00

12 lines
528 B
Makefile

$NetBSD: patch-xen_arch_x86_Rules.mk,v 1.1 2018/07/24 13:40:11 bouyer Exp $
--- xen/arch/x86/Rules.mk.orig 2018-04-17 19:21:31.000000000 +0200
+++ xen/arch/x86/Rules.mk 2018-04-23 13:31:24.000000000 +0200
@@ -8,6 +8,7 @@
CFLAGS += -I$(BASEDIR)/include/asm-x86/mach-default
CFLAGS += -DXEN_IMG_OFFSET=$(XEN_IMG_OFFSET)
CFLAGS += '-D__OBJECT_LABEL__=$(subst /,$$,$(subst -,_,$(subst $(BASEDIR)/,,$(CURDIR))/$@))'
+CFLAGS += $(EXTRA_CFLAGS)
# Prevent floating-point variables from creeping into Xen.
CFLAGS += -msoft-float