pkgsrc/lang/joos/patches/patch-ac
jschauma e14a1e0c8b Initial import of "Joos":
Joos is an acronym for Java's Object-Oriented Subset. JOOS is a
proper subset of Java which is used to teach students about compilers.
2002-05-08 15:42:00 +00:00

20 lines
517 B
Text

$NetBSD: patch-ac,v 1.1 2002/05/08 15:42:02 jschauma Exp $
--- D-Java/Makefile.orig Wed May 8 10:33:44 2002
+++ D-Java/Makefile Wed May 8 10:33:58 2002
@@ -1,6 +1,3 @@
-CC = gcc
-CFLAGS = -Wall -O2
-
objects = d-java.o err_str.o getbytes.o labels.o lltoa.o \
opcodes.o packages.o reclass.o shattrib.o shclass.o \
shconst.o shjasmin.o
@@ -8,7 +5,7 @@
target = D-Java
$(target) : $(objects)
- gcc -o $(target) $(objects)
+ $(CC) -o $(target) $(objects)
d-java.o : d-java.h
err_str.o :