4b440744a5
Update apcupsd package to 3.14.14. 3.14.14 -- 31 May 2016 BUG FIXES * win32: Fix missing DLLs when installing only apctray * Fixes for socket error handling. Resolves apcaccess crash when connection fails as well as several other theoretical issues. * MODBUS/USB error handling (COMMLOST) improvements for faulty USB links * Fix hiddev binding when usbfs is mounted on /dev/bus/usb instead of /proc/bus/usb. This is necessary for switching between MODBUS/USB and USB/HID on Linux. * Update GPLv2 text and FSF address to match current versions from FSF. * Various fixes for potential issues suggested by Coverity Scan * MacOS X port support for El Capitan System Integrity Protection (SIP) aka "rootless" * Fix shutdown failure on Windows when UPSNAME includes spaces * Fix building bsd-usb driver (This was broken when modbus-usb support was added.) FEATURES * Add status display for output current as well as apparent power
58 lines
1.4 KiB
Text
58 lines
1.4 KiB
Text
$NetBSD: patch-ae,v 1.8 2020/09/19 13:50:48 taca Exp $
|
|
|
|
* Fix for pkgsrc environment.
|
|
* Add Dragonfly support.
|
|
* Add apccontrol script on NetBSD.
|
|
|
|
--- autoconf/configure.in.orig 2010-09-02 16:23:39.000000000 +0200
|
|
+++ autoconf/configure.in 2011-08-01 15:40:05.000000000 +0200
|
|
@@ -89,12 +89,6 @@
|
|
sysconfdir='/etc/apcupsd'
|
|
fi
|
|
|
|
-dnl
|
|
-dnl If the user has not set -sbindir, we set our default as /sbin
|
|
-dnl
|
|
- if test x$sbindir = x'${exec_prefix}/sbin' ; then
|
|
- sbindir='/sbin'
|
|
- fi
|
|
fi
|
|
|
|
dnl
|
|
@@ -146,7 +140,7 @@
|
|
AC_SUBST(PTHREAD_LFLAGS)
|
|
|
|
APCACCESS=apcaccess
|
|
-SMTP=smtp
|
|
+SMTP=
|
|
APCTEST=apctest
|
|
AC_SUBST(APCACCESS)
|
|
AC_SUBST(SMTP)
|
|
@@ -989,7 +983,7 @@
|
|
elif test $HAVE_UNAME=yes -a x`uname -s` = xFreeBSD
|
|
then
|
|
DISTNAME=freebsd
|
|
-elif test $HAVE_UNAME=yes -a x`uname -s` = xNetBSD
|
|
+elif test $HAVE_UNAME=yes -a x`uname -s` = xNetBSD || test $HAVE_UNAME=yes -a x`uname -s` = xDragonFly
|
|
then
|
|
DISTNAME=netbsd
|
|
elif test $HAVE_UNAME=yes -a x`uname -s` = xOpenBSD
|
|
@@ -1130,7 +1124,7 @@
|
|
platforms/debian/apcupsd \
|
|
platforms/debian/ups-monitor"
|
|
;;
|
|
-freebsd)
|
|
+freebsd|dragonfly)
|
|
DISTVER=`uname -a |awk '{print $3}'`
|
|
SERIALDEV=/dev/cuaa0
|
|
nologdir=/var/run
|
|
@@ -1164,7 +1158,8 @@
|
|
PTHREAD_LFLAGS=""
|
|
LDFLAGS="$LDFLAGS -pthread"
|
|
DFILES="\
|
|
- platforms/netbsd/apcupsd"
|
|
+ platforms/netbsd/apcupsd \
|
|
+ platforms/netbsd/apccontrol"
|
|
;;
|
|
openbsd)
|
|
DISTVER=`uname -a |awk '{print $3}'`
|