pkgsrc/devel/gperf/patches/patch-aa
adam ce13bf5848 New in 3.0.1:
* Bug fix.

New in 3.0:
* Added option --output that allows to specify the output file name.
* Some options have been renamed:
    --hash-fn-name=NAME     -->   --hash-function-name=NAME
    --lookup-fn-name=NAME   -->   --lookup-function-name=NAME
    --compare-strlen        -->   --compare-lengths
    --global                -->   --global-table
  The older variants are still supported for backward compatibility.
* New options can now be specified inside the input file: --> see "NEWS"
* When the option -k is not given, the default key positions are now
  computed depending on the set of keywords.
* If the input file is given by name, the output file will now contain
  #line directives referring to the input file.
* Some keyword sets containing permutations, like { "xy", "yx", "xz", "zx" }
  or { "abc", "acb", "bca", "cab" }, are now handled by gperf without
  requiring the option -D.
* The generated table is usually much smaller than it was with earlier
  versions of gperf.
* Added option -m/--multiple-iterations that allows to further reduce the
  size of the generated table.
* When the search for a good hash function is not immediately successful,
  the table's size will grow as needed. Earlier versions of gperf bailed
  out with an "Internal error, duplicate hash code value".
* The options -f/--fast and -o/--occurrence-sort have no effect any more.
* Added options -P/--pic and --null-strings that optimize the generated code
  for use in shared libraries. -P/--pic does a perfect optimization but may
  require some small code changes (see the documentation for details), whereas
  --null-strings does only a half-hearted optimization but works without
  needing any change to surrounding code.
* Added option --ignore-case that produces a case independent lookup function.
* Bug fixes
2003-12-03 15:56:16 +00:00

32 lines
1.1 KiB
Text

$NetBSD: patch-aa,v 1.5 2003/12/03 15:56:16 adam Exp $
--- doc/Makefile.in.orig 2003-06-02 13:42:02.000000000 +0200
+++ doc/Makefile.in
@@ -49,7 +49,6 @@ TEX = tex
TEXI2DVI = texi2dvi
DVIPS = dvips -D600
TEXI2PDF = texi2pdf
-MAKEINFO = LANG= LANGUAGE= makeinfo
TEXI2HTML = texi2html
# Programs used by "make install":
@@ -116,8 +115,8 @@ install : all force
# $(INSTALL_DATA) $(srcdir)/gperf.ps $(DESTDIR)$(psdir)/gperf.ps
# $(MKINSTALLDIRS) $(DESTDIR)$(pdfdir)
# $(INSTALL_DATA) $(srcdir)/gperf.pdf $(DESTDIR)$(pdfdir)/gperf.pdf
- $(MKINSTALLDIRS) $(DESTDIR)$(htmldir)
- $(INSTALL_DATA) $(srcdir)/gperf.html $(DESTDIR)$(htmldir)/gperf.html
+# $(MKINSTALLDIRS) $(DESTDIR)$(htmldir)
+# $(INSTALL_DATA) $(srcdir)/gperf.html $(DESTDIR)$(htmldir)/gperf.html
installdirs : force
$(MKINSTALLDIRS) $(DESTDIR)$(infodir)
@@ -125,7 +124,7 @@ installdirs : force
# $(MKINSTALLDIRS) $(DESTDIR)$(dvidir)
# $(MKINSTALLDIRS) $(DESTDIR)$(psdir)
# $(MKINSTALLDIRS) $(DESTDIR)$(pdfdir)
- $(MKINSTALLDIRS) $(DESTDIR)$(htmldir)
+# $(MKINSTALLDIRS) $(DESTDIR)$(htmldir)
uninstall : force
$(RM) $(DESTDIR)$(infodir)/gperf.info