4ba262c7c1
Use /dev/sound on NetBSD. Bring in ossaudio via buildlink3. Bump PKGREVISION. Fixes the problems reported in PR 26206 by Ole Hellqvist
34 lines
852 B
Text
34 lines
852 B
Text
$NetBSD: patch-ab,v 1.1 2004/07/08 18:33:07 agc Exp $
|
|
|
|
--- bplaysrc/Makefile 2004/07/08 15:10:58 1.1
|
|
+++ bplaysrc/Makefile 2004/07/08 15:12:18
|
|
@@ -6,18 +6,24 @@
|
|
../clrscr.o ../secshms.o
|
|
#SRCS = bplay.c sndfunc.o shmbuf.c
|
|
|
|
-CC = gcc
|
|
-LDFLAGS =
|
|
+#CC = gcc
|
|
+#LDFLAGS =
|
|
|
|
########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see ../Makefile!)
|
|
|
|
+OS= $(shell uname -s)
|
|
+
|
|
+ifeq (${OS}, Linux)
|
|
# For Linux (and maybe others), use these:
|
|
CFLAGS = -Wall -O2 -DUSEBUFFLOCK -DREDHAT50 -DLP2CD -DVUMETER # -DDEBUG
|
|
LIBS = -lncurses
|
|
-
|
|
+else
|
|
+ifeq (${OS}, NetBSD)
|
|
# For FreeBSD (and maybe others), use these:
|
|
-#CFLAGS = -Wall -O2 -DLP2CD -DVUMETER # -DDEBUG
|
|
-#LIBS = -lncurses
|
|
+CFLAGS = -Wall -O2 -DLP2CD -DVUMETER -DOLD_CURSES -D_SEM_SEMUN_UNDEFINED # -DDEBUG
|
|
+LIBS = -lcurses ${LIBOSSAUDIO}
|
|
+endif
|
|
+endif
|
|
|
|
# -DOLD_CURSES can be used here, too.
|
|
|