As a side effect this should make apcupsd build on netbsd-4 and current. pkgsrc changes: cgi and snmp are now enabled by default. Relevant changes since 3.12.4: Unreliable MASTER/SLAVE networking mode is removed PowerChute Network Shutdown driver (protocol available in the AP9617 family of smart slot modules) New configuration directives to set paths at runtime
70 lines
2.1 KiB
Text
70 lines
2.1 KiB
Text
$NetBSD: patch-aj,v 1.7 2007/06/15 19:05:57 bouyer Exp $
|
|
|
|
--- configure.orig 2007-06-15 13:48:18.000000000 +0200
|
|
+++ configure 2007-06-15 13:48:42.000000000 +0200
|
|
@@ -1538,9 +1538,6 @@
|
|
sysconfdir='/etc/apcupsd'
|
|
fi
|
|
|
|
- if test x$sbindir = x'${exec_prefix}/sbin' ; then
|
|
- sbindir='/sbin'
|
|
- fi
|
|
fi
|
|
|
|
# Make sure we can run config.sub.
|
|
@@ -3578,7 +3575,7 @@
|
|
|
|
|
|
APCACCESS=apcaccess
|
|
-SMTP=smtp
|
|
+SMTP=
|
|
APCTEST=apctest
|
|
|
|
|
|
@@ -10687,7 +10684,7 @@
|
|
fi
|
|
fi
|
|
|
|
-if test $HAVE_UNAME=yes -a x`uname -s` = xFreeBSD
|
|
+if test $HAVE_UNAME=yes -a x`uname -s` = xFreeBSD || test $HAVE_UNAME=yes -a x`uname -s` = xDragonFly
|
|
then
|
|
|
|
|
|
@@ -11751,7 +11748,8 @@
|
|
echo "${ECHO_T}Using Linux USB driver." >&6
|
|
elif test $GENERICUSB = "no" -a $HAVE_UNAME=yes -a x`uname -s` = xFreeBSD -o \
|
|
$GENERICUSB = "no" -a $HAVE_UNAME=yes -a x`uname -s` = xOpenBSD -o \
|
|
- $GENERICUSB = "no" -a $HAVE_UNAME=yes -a x`uname -s` = xNetBSD ; then
|
|
+ $GENERICUSB = "no" -a $HAVE_UNAME=yes -a x`uname -s` = xNetBSD -o \
|
|
+ $GENERICUSB = "no" -a $HAVE_UNAME=yes -a x`uname -s` = xDragonFly ; then
|
|
LIBUSBHIDINC="-I\$(topdir)/src/libusbhid"
|
|
LIBUSBHID=libusbhid
|
|
LIBUSBHIDOBJS="\$(topdir)/src/libusbhid/*.o"
|
|
@@ -16723,7 +16721,7 @@
|
|
elif test $HAVE_UNAME=yes -a x`uname -s` = xFreeBSD
|
|
then
|
|
DISTNAME=freebsd
|
|
-elif test $HAVE_UNAME=yes -a x`uname -s` = xNetBSD
|
|
+elif test $HAVE_UNAME=yes -a x`uname -s` = xNetBSD || test $HAVE_UNAME=yes -a x`uname -s` = xDragonFly
|
|
then
|
|
DISTNAME=netbsd
|
|
elif test $HAVE_UNAME=yes -a x`uname -s` = xOpenBSD
|
|
@@ -16842,7 +16840,7 @@
|
|
platforms/debian/apcupsd \
|
|
platforms/debian/ups-monitor"
|
|
;;
|
|
-freebsd)
|
|
+freebsd|dragonfly)
|
|
DISTVER=`uname -a |awk '{print $3}'`
|
|
SERIALDEV=/dev/cuaa0
|
|
nologdir=/var/run
|
|
@@ -16880,7 +16878,8 @@
|
|
LDFLAGS="$LDFLAGS -pthread"
|
|
DFILES="\
|
|
platforms/netbsd/Makefile \
|
|
- platforms/netbsd/apcupsd"
|
|
+ platforms/netbsd/apcupsd \
|
|
+ platforms/netbsd/apccontrol"
|
|
;;
|
|
openbsd)
|
|
DISTVER=`uname -a |awk '{print $3}'`
|