86 lines
3.5 KiB
Text
86 lines
3.5 KiB
Text
$NetBSD: patch-aa,v 1.6 2010/11/03 11:39:08 adam Exp $
|
|
|
|
--- Makefile.in.orig 2009-11-06 10:29:34.000000000 +0000
|
|
+++ Makefile.in
|
|
@@ -37,7 +37,7 @@ POST_UNINSTALL = :
|
|
build_triplet = @build@
|
|
host_triplet = @host@
|
|
target_triplet = @target@
|
|
-noinst_PROGRAMS = pam_ldap.so$(EXEEXT)
|
|
+noinst_PROGRAMS = pam_ldap.la
|
|
DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
|
|
$(srcdir)/Makefile.in $(srcdir)/config.h.in \
|
|
$(top_srcdir)/configure AUTHORS COPYING COPYING.LIB ChangeLog \
|
|
@@ -54,14 +54,13 @@ mkinstalldirs = $(SHELL) $(top_srcdir)/m
|
|
CONFIG_HEADER = config.h
|
|
CONFIG_CLEAN_FILES =
|
|
PROGRAMS = $(noinst_PROGRAMS)
|
|
-am_pam_ldap_so_OBJECTS = pam_ldap.$(OBJEXT) md5.$(OBJEXT) \
|
|
- vers.$(OBJEXT)
|
|
+am_pam_ldap_so_OBJECTS = pam_ldap.$(OBJEXT) md5.$(OBJEXT)
|
|
pam_ldap_so_OBJECTS = $(am_pam_ldap_so_OBJECTS)
|
|
pam_ldap_so_LDADD = $(LDADD)
|
|
DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
|
|
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
am__depfiles_maybe = depfiles
|
|
-COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
|
+COMPILE = ${LIBTOOL} --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
|
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
|
CCLD = $(CC)
|
|
SOURCES = $(pam_ldap_so_SOURCES)
|
|
@@ -189,7 +188,7 @@ all: config.h
|
|
$(MAKE) $(AM_MAKEFLAGS) all-am
|
|
|
|
.SUFFIXES:
|
|
-.SUFFIXES: .c .o .obj
|
|
+.SUFFIXES: .c .lo .o .obj
|
|
am--refresh:
|
|
@:
|
|
$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
|
|
@@ -243,6 +242,8 @@ distclean-hdr:
|
|
|
|
clean-noinstPROGRAMS:
|
|
-test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
|
|
+pam_ldap.la: $(pam_ldap_so_OBJECTS:.o=.lo) $(pam_ldap_so_DEPENDENCIES)
|
|
+ ${LIBTOOL} --mode=link $(CC) $(AM_LDFLAGS) $(LDFLAGS) $(pam_ldap_so_LDFLAGS) $(pam_ldap_so_OBJECTS:.o=.lo) -module -avoid-version -rpath $(libdir)/security -o $@ $(pam_ldap_so_LDADD) $(LIBS)
|
|
pam_ldap.so$(EXEEXT): $(pam_ldap_so_OBJECTS) $(pam_ldap_so_DEPENDENCIES)
|
|
@rm -f pam_ldap.so$(EXEEXT)
|
|
$(LINK) $(pam_ldap_so_LDFLAGS) $(pam_ldap_so_OBJECTS) $(pam_ldap_so_LDADD) $(LIBS)
|
|
@@ -257,7 +258,7 @@ distclean-compile:
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pam_ldap.Po@am__quote@
|
|
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/vers.Po@am__quote@
|
|
|
|
-.c.o:
|
|
+.c.lo:
|
|
@am__fastdepCC_TRUE@ if $(COMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; \
|
|
@am__fastdepCC_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
|
|
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
@@ -592,7 +593,14 @@ uninstall-man: uninstall-man5
|
|
uninstall-man5
|
|
|
|
|
|
-install-exec-local: pam_ldap.so
|
|
+install-exec-local: install-exec-local-libtool
|
|
+
|
|
+install-exec-local-libtool: pam_ldap.la
|
|
+ @$(NORMAL_INSTALL)
|
|
+ $(mkinstalldirs) $(DESTDIR)$(libdir)/security
|
|
+ ${LIBTOOL} --mode=install $(INSTALL_PROGRAM) -c pam_ldap.la $(DESTDIR)$(libdir)/security
|
|
+
|
|
+install-exec-local-so: pam_ldap.so
|
|
@$(NORMAL_INSTALL)
|
|
$(mkinstalldirs) $(DESTDIR)$(libdir)/security
|
|
@EXTENSION_SO_TRUE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so
|
|
@@ -602,10 +610,8 @@ install-exec-local: pam_ldap.so
|
|
|
|
install-data-local:
|
|
@$(NORMAL_INSTALL)
|
|
- @if test ! -f $(DESTDIR)$(sysconfdir)/ldap.conf; then \
|
|
- $(mkinstalldirs) $(DESTDIR)$(sysconfdir); \
|
|
- $(INSTALL_DATA) -o root -g root $(srcdir)/ldap.conf $(DESTDIR)$(sysconfdir)/ldap.conf; \
|
|
- fi
|
|
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
|
|
+ $(INSTALL_DATA) $(srcdir)/ldap.conf $(DESTDIR)$(sysconfdir)/ldap.conf; \
|
|
|
|
uninstall-local:
|
|
@$(NORMAL_UNINSTALL)
|