Make sure the configure script finds the ping or ping6 command on NetBSD, don't rely on /sbin being in $path of the builder. Not sure if similar change is needed for other $OPSYS. Add a comment to patch-ad explaining why some plugins are disabled here.
27 lines
1.7 KiB
Text
27 lines
1.7 KiB
Text
$NetBSD: patch-ad,v 1.6 2016/10/01 18:23:18 bouyer Exp $
|
|
Exclude plugins that would require extra dependancies.
|
|
Some can be found in specific nagios plugin packages.
|
|
|
|
--- plugins-scripts/Makefile.in.orig 2014-06-26 16:17:33.000000000 +0000
|
|
+++ plugins-scripts/Makefile.in
|
|
@@ -1288,15 +1288,11 @@ top_srcdir = @top_srcdir@
|
|
with_trusted_path = @with_trusted_path@
|
|
@RELEASE_PRESENT_TRUE@NP_VERSION = @NP_RELEASE@
|
|
SUFFIXES = .pl .sh
|
|
-libexec_SCRIPTS = check_breeze check_disk_smb check_flexlm check_ircd \
|
|
- check_log check_oracle check_rpc check_sensors check_wave \
|
|
- check_ifstatus check_ifoperstatus check_mailq check_file_age \
|
|
- utils.sh utils.pm
|
|
-
|
|
-EXTRA_DIST = check_breeze.pl check_disk_smb.pl check_flexlm.pl check_ircd.pl \
|
|
- check_log.sh check_ntp.pl check_oracle.sh check_rpc.pl check_sensors.sh \
|
|
- check_ifstatus.pl check_ifoperstatus.pl check_wave.pl check_mailq.pl check_file_age.pl \
|
|
- utils.sh.in utils.pm.in t
|
|
+libexec_SCRIPTS = check_ircd check_log check_ntp check_rpc check_mailq \
|
|
+ check_file_age utils.sh utils.pm
|
|
+
|
|
+EXTRA_DIST = check_ircd.pl check_log.sh check_ntp.pl check_rpc.pl \
|
|
+ check_mailq.pl check_file_age.pl utils.sh.in utils.pm.in t
|
|
|
|
TESTS_ENVIRONMENT = perl -I $(top_builddir) -I $(top_srcdir)
|
|
TESTS = @SCRIPT_TEST@
|