pkgsrc/devel/poco/patches/patch-ah
schnoebe f585e7443c Import Poco 1.4.0
The POCO C++ Libraries (POCO stands for POrtable COmponents) are
open source C++ class libraries that simplify and accelerate the
development of network-centric, portable applications in C++. The
libraries integrate perfectly with the C++ Standard Library and
fill many of the functional gaps left open by it. Their modular
and efficient design and implementation makes the POCO C++ Libraries
extremely well suited for embedded development, an area where the
C++ programming language is becoming increasingly popular, due to
its suitability for both low-level (device I/O, interrupt handlers,
etc.) and high-level object-oriented development. Of course, the
POCO C++ Libraries are also ready for enterprise-level challenges.
2011-02-06 05:55:14 +00:00

18 lines
683 B
Text

$NetBSD: patch-ah,v 1.1.1.1 2011/02/06 05:55:15 schnoebe Exp $
# simplify the search for the MySQL components, since we know
# where they are..
--- Data/MySQL/Makefile.orig 2009-05-12 13:22:14.000000000 -0500
+++ Data/MySQL/Makefile
@@ -8,8 +8,8 @@
include $(POCO_BASE)/build/rules/global
-SYSLIBS += -L/usr/local/lib/mysql -L/usr/lib/mysql -L/usr/mysql/lib/mysql -L/usr/local/mysql/lib -lmysqlclient
-INCLUDE += -I/usr/local/include/mysql/ -I/usr/include/mysql -I/usr/mysql/include/mysql -I/usr/local/mysql/include
+SYSLIBS += -L@MYSQLLIBDIR@ -lmysqlclient
+INCLUDE += -I@MYSQLINCDIR@
SYSFLAGS += -DTHREADSAFE -DNO_TCL
objects = Binder Extractor SessionImpl Connector \