pkgsrc/inputmethod/ibus-table-chinese/patches/patch-tables_array_CMakeLists.txt
obache 6c1a4d0406 Update ibus-table-chinese to 1.4.6.
* Sat Dec 22 2012 Ding-Yi Chen <dchen@redhat.com> - 1.4.6
- Fixed IBus Google issue 1126: An error in ChineseTableLicenseAuditing
- Complete LICENSE tag for all of the tables.

* Mon Nov 26 2012 Ding-Yi Chen <dchen@redhat.com> - 1.4.5
- Table build scripts has been refactored.
- cmake-fedora is added as submodule.
- Fixed Bug 855250 - Change the default filtering for Quick and Cangjie by
  merging maxiaojun's repository
- Fixed Google Issue 1405: failed to build ibus-table-chinese due to missing db files
- Fixed Google issue 1507: Add CJKV Extension C/D support for Array30
- Merge GitHub Pull request 3: Added the inter punct
- Merge GitHub Pull request 4: Give Cangjie and Quick users 9 candidates per page
2012-12-22 08:58:14 +00:00

28 lines
1.2 KiB
Text

$NetBSD: patch-tables_array_CMakeLists.txt,v 1.2 2012/12/22 08:58:15 obache Exp $
* use more portable codeset names.
--- tables/array/CMakeLists.txt.orig 2012-11-23 00:36:57.000000000 +0000
+++ tables/array/CMakeLists.txt
@@ -16,7 +16,7 @@ SET(ARRAY30_BASE_HEAD "${ARRAY30_BASE}.h
CONFIGURE_FILE(${ARRAY30_HEAD_IN} ${ARRAY30_BASE_HEAD} @ONLY)
-CONVERT_ENCODING(${ARRAY30_BASE_UTF8} UTF16 array30_27489.txt)
+CONVERT_ENCODING(${ARRAY30_BASE_UTF8} UTF-16 array30_27489.txt)
GENERATE_FREQ(${ARRAY30_BASE_FREQ}
${ARRAY30_BASE_UTF8}
)
@@ -41,10 +41,10 @@ SET(ARRAY30_BIG_HEAD "${ARRAY30_BIG}.hea
CONFIGURE_FILE(${ARRAY30_HEAD_IN} ${ARRAY30_BIG_HEAD} @ONLY)
SET(ARRAY30_EXT_B_UTF8 ${CMAKE_CURRENT_BINARY_DIR}/array30_ExtB.utf8)
-CONVERT_ENCODING(${CMAKE_CURRENT_BINARY_DIR}/array30_ExtB.utf8 UTF16 array30_ExtB.txt)
+CONVERT_ENCODING(${CMAKE_CURRENT_BINARY_DIR}/array30_ExtB.utf8 UTF-16 array30_ExtB.txt)
SET(ARRAY30_EXT_CD_UTF8 ${CMAKE_CURRENT_BINARY_DIR}/array30_ExtCD.utf8)
-CONVERT_ENCODING(${CMAKE_CURRENT_BINARY_DIR}/array30_ExtCD.utf8 UTF16 array30_ExtCD_V2012A.txt)
+CONVERT_ENCODING(${CMAKE_CURRENT_BINARY_DIR}/array30_ExtCD.utf8 UTF-16 array30_ExtCD_V2012A.txt)
ADD_CUSTOM_COMMAND(OUTPUT ${ARRAY30_BIG_UTF8}
COMMAND cat ${ARRAY30_BASE_UTF8}