f9ac87c37a
Changes since last packaged version (1.5.5): 2008-02-22 - Add icmp type/code decoding - Add proper icmp v9 decoding - Fix memory leaks in -e auto expire mode in nfcapd. - Fix somee potential dead locks with file locking, when expiring - Fix multicast bug in nfreplay - Add hostname lookup for IP addresses in filter. 2007-10-15 stable-1.5.6 - Fix odd CISCO behaviour for ICMP type/code in src port. - Add fast LZO1X-1 compression option (-z) for output file. - Add lists for port in syntax -> port in [ 135 137 445] - Add lists for AS syntax -> as in [ 1024 1025 ] - Bug fix in filter for syntax 'src as and dst as'
50 lines
1.5 KiB
Text
50 lines
1.5 KiB
Text
$NetBSD: patch-ag,v 1.2 2008/02/24 20:38:49 seb Exp $
|
|
|
|
--- configure.orig 2008-02-24 19:52:42.000000000 +0000
|
|
+++ configure
|
|
@@ -1,5 +1,5 @@
|
|
#! /bin/sh
|
|
-# From configure.in Revision: 95 .
|
|
+# From configure.in Revision: 97 .
|
|
# Guess values for system-dependent variables and create Makefiles.
|
|
# Generated by GNU Autoconf 2.59 for nfdump 1.5.5.
|
|
#
|
|
@@ -3971,7 +3971,7 @@ echo "$as_me: error: Link with \"-lz\" f
|
|
fi
|
|
|
|
if test -d "$WHERE_FTPATH"; then
|
|
- if test ! -f "$WHERE_FTPATH/lib/ftlib.h"; then
|
|
+ if test ! -f "$WHERE_FTPATH/include/flow-tools/ftlib.h"; then
|
|
{ { echo "$as_me:$LINENO: error: ftlib.h file not found in flow-tools directory '$WHERE_FTPATH'. Use --with-ftpath=PATH" >&5
|
|
echo "$as_me: error: ftlib.h file not found in flow-tools directory '$WHERE_FTPATH'. Use --with-ftpath=PATH" >&2;}
|
|
{ (exit 1); exit 1; }; }
|
|
@@ -3981,7 +3981,7 @@ echo "$as_me: error: ftlib.h file not fo
|
|
echo "$as_me: error: libft.a not found in flow-tools directory '$WHERE_FTPATH'. Build flow tools first" >&2;}
|
|
{ (exit 1); exit 1; }; }
|
|
fi
|
|
- FT_INCLUDES="-I$WHERE_FTPATH/src -I$WHERE_FTPATH/lib"
|
|
+ FT_INCLUDES="-I$WHERE_FTPATH/include/flow-tools"
|
|
FT_LDFLAGS="-L$WHERE_FTPATH/lib"
|
|
else
|
|
{ { echo "$as_me:$LINENO: error: flow-tools directory '$WHERE_FTPATH' does not exists. Use --with-ftpath=PATH" >&5
|
|
@@ -3990,9 +3990,6 @@ echo "$as_me: error: flow-tools director
|
|
fi
|
|
opt_objects=ft2nfdump
|
|
|
|
-else
|
|
- opt_objects=
|
|
-
|
|
fi;
|
|
|
|
ac_ext=c
|
|
@@ -4777,9 +4774,7 @@ rm -f core *.core gmon.out bb.out confte
|
|
fi
|
|
|
|
|
|
-
|
|
-else
|
|
- opt_objects=
|
|
+opt_objects="$opt_objects nfprofile"
|
|
|
|
fi;
|
|
|