pkgsrc/devel/libslang/patches/patch-ab
jlam 4c2fe71631 + Pass down the correct values for TERMCAP (the options to link to
the library containing termcap functions) and MISC_TERMINFO_DIRS
  (the location of the terminfo database).  Patch the configure script
  to use these values instead of using its own broken logic to determine
  the same information.

+ Include termlib.buildlink3.mk to determine the right terminal library
  to use.

The above two changes should fix PR pkg/30725.

+ Move the HTML documentation into ${PREFIX}/share/doc/slang.

Bump the PKGREVISION to 6.
2008-02-29 16:44:55 +00:00

23 lines
590 B
Text

$NetBSD: patch-ab,v 1.8 2008/02/29 16:44:55 jlam Exp $
--- configure.orig 2003-03-23 02:06:40.000000000 -0500
+++ configure
@@ -2320,6 +2320,10 @@ EOF
+# pkgsrc will supply definitions for MISC_TERMINFO_DIRS and TERMCAP
+# in order to ensure the correct termcap library is used.
+#
+if false; then
echo $ac_n "checking for Terminfo""... $ac_c" 1>&6
echo "configure:2325: checking for Terminfo" >&5
MISC_TERMINFO_DIRS="$FINKPREFIX/share/terminfo"
@@ -2345,6 +2349,7 @@ do
break
fi
done
+fi
if test "$TERMCAP"; then
echo "$ac_t""no" 1>&6
cat >> confdefs.h <<\EOF