3b3aa4d490
The mastersite resolves to a parking domain, causing the html page to be interpreted as a tarball download which doesn't pass the checksum of course. Luckily this tarball is backed up at NetBSD, so remove the mastersite so it can fall back to NetBSD. Secondly, a patch from 2007 was mispelled and was never included into the distinfo. Obviously it built anyway, but the patch was renamed and the distinfo file regenerated.
22 lines
986 B
Text
22 lines
986 B
Text
$NetBSD: patch-al,v 1.1 2011/12/14 18:31:48 marino Exp $
|
|
|
|
--- server/TLS_TcpipMain.cpp.orig 2000-06-14 04:00:01.000000000 +0000
|
|
+++ server/TLS_TcpipMain.cpp
|
|
@@ -91,7 +91,7 @@ static void *handler(void *_arg)
|
|
printf ("========== Begin New Client Socket =========== \n");
|
|
/* read request */
|
|
while (bExit == 0) {
|
|
- n = MyTLS_CPthSocket.read (caLine, MAXREQLINE);
|
|
+ n = MyTLS_CPthSocket.socket_read (caLine, MAXREQLINE);
|
|
if (n < 0) {
|
|
fprintf(stderr, "read error: errno=%d\n", errno);
|
|
close(fd);
|
|
@@ -237,7 +237,7 @@ static void *handler(void *_arg)
|
|
}
|
|
/* simulate a little bit of processing ;) */
|
|
pth_yield (NULL);
|
|
- n = MyTLS_CPthSocket.write (MemOut->pGetBuf (), MemOut->GetBufLen());
|
|
+ n = MyTLS_CPthSocket.socket_write (MemOut->pGetBuf (), MemOut->GetBufLen());
|
|
//pth_write(fd, MemOut->pGetBuf (), MemOut->GetBufLen());
|
|
}
|
|
/* close connection and let thread die */
|