pkgsrc/devel/poco/patches/patch-ai
schnoebe f585e7443c Import Poco 1.4.0
The POCO C++ Libraries (POCO stands for POrtable COmponents) are
open source C++ class libraries that simplify and accelerate the
development of network-centric, portable applications in C++. The
libraries integrate perfectly with the C++ Standard Library and
fill many of the functional gaps left open by it. Their modular
and efficient design and implementation makes the POCO C++ Libraries
extremely well suited for embedded development, an area where the
C++ programming language is becoming increasingly popular, due to
its suitability for both low-level (device I/O, interrupt handlers,
etc.) and high-level object-oriented development. Of course, the
POCO C++ Libraries are also ready for enterprise-level challenges.
2011-02-06 05:55:14 +00:00

62 lines
2 KiB
Text

$NetBSD: patch-ai,v 1.1.1.1 2011/02/06 05:55:15 schnoebe Exp $
# simplify the search for ODBC components, since we control where they
# are in pkgsrc
#
# someday, make it able to use either unixodbc or iodbc
--- Data/ODBC/Makefile.orig 2010-12-16 05:43:32.000000000 +0000
+++ Data/ODBC/Makefile
@@ -9,44 +9,18 @@
include $(POCO_BASE)/build/rules/global
# adjust for the target system (usually '/usr/lib' or '/usr/local/lib')
-ODBCLIBDIR = /usr/lib
+ODBCLIBDIR = @ODBCLIBDIR@
-INCLUDE += -I/usr/local/include -I/usr/include -I/usr/include/odbc -I/usr/local/include/odbc
-SYSLIBS += -L/usr/local/lib/odbc -L/usr/lib/odbc -L/usr/lib -L/usr/local/lib
+INCLUDE += -I@ODBCINCDIR@
+SYSLIBS += -L@ODBCLIBDIR@
-ifeq ($(POCO_CONFIG),MinGW)
-# Lack of unixODBC or iODBC is not an error for MinGW platform since it uses Windows odbc32.lib
-else
-ifeq ($(POCO_CONFIG),CYGWIN)
-# -DODBCVER=0x0300: SQLHandle declaration issue
-# -DNOMINMAX : MIN/MAX macros defined in windows conflict with libstdc++
-CXXFLAGS += -DODBCVER=0x0300 -DNOMINMAX
-# CYGWIN platform has its own ODBC library in /lib/w32api
-SYSLIBS += -L/lib/w32api -lodbc32 -lodbccp32
-else
-ifeq (0, $(shell test -e $(ODBCLIBDIR)/libodbc$(SHAREDLIBLINKEXT); echo $$?))
-SYSLIBS += -lodbc -lodbcinst
+# with unixodbc
COMMONFLAGS += -DPOCO_UNIXODBC
-else
-ifeq (0, $(shell test -h $(ODBCLIBDIR)/libodbc$(SHAREDLIBLINKEXT); echo $$?))
SYSLIBS += -lodbc -lodbcinst
-COMMONFLAGS += -DPOCO_UNIXODBC
-else
-ifeq (0, $(shell test -e $(ODBCLIBDIR)/libiodbc$(SHAREDLIBLINKEXT); echo $$?))
-SYSLIBS += -liodbc -liodbcinst
-COMMONFLAGS += -DPOCO_IODBC
-else
-ifeq (0, $(shell test -h $(ODBCLIBDIR)/libiodbc$(SHAREDLIBLINKEXT); echo $$?))
-SYSLIBS += -liodbc -liodbcinst
-COMMONFLAGS += -DPOCO_IODBC
-else
-$(error No ODBC library found. Please install unixODBC or iODBC and try again)
-endif
-endif
-endif
-endif
-endif
-endif
+
+# with iodbc
+# SYSLIBS += -liodbc -liodbcinst
+# COMMONFLAGS += -DPOCO_IODBC
objects = Binder ConnectionHandle Connector DataTypes EnvironmentHandle \
Extractor ODBCColumn ODBCException ODBCStatementImpl \