pkgsrc/www/apache2/patches/patch-ai
jlam 3618dd36af Modify the apxs(8) script to use ${APR_LIBTOOL} as the libtool to
build modules if APR_LIBTOOL is defined in the environment.  Force
the use of the libtool wrapper by module packages by setting APR_LIBTOOL
in apache2/buildlink3.mk.  Bump the PKGREVISION.
2004-11-30 23:21:43 +00:00

20 lines
578 B
Text

$NetBSD: patch-ai,v 1.6 2004/11/30 23:21:44 jlam Exp $
--- support/apxs.in.orig 2004-02-09 15:59:49.000000000 -0500
+++ support/apxs.in
@@ -337,9 +337,12 @@ if (! -x "$apu_bindir/apu-config") {
exit(1);
}
-my $libtool = `$apr_bindir/apr-config --installbuilddir`;
-chomp($libtool);
-$libtool = "$libtool/libtool";
+my $libtool = $ENV{'APR_LIBTOOL'};
+unless ($libtool) {
+ $libtool = `$apr_bindir/apr-config --installbuilddir`;
+ chomp($libtool);
+ $libtool = "$libtool/libtool";
+}
my $apr_includedir = `$apr_bindir/apr-config --includes`;
chomp($apr_includedir);