pkgsrc/devel/scmgit/patches/patch-ah
bjs 7f89de3688 Update to scmgit-1.5.3.1. Changes are too numerous to list here; please
see Documentation/RelNotes-1.5.3.1.txt (in ${WRKSRC} or the GIT tree).
2007-09-11 09:23:54 +00:00

34 lines
1.3 KiB
Text

$NetBSD: patch-ah,v 1.3 2007/09/11 09:23:55 bjs Exp $
--- git-gui/Makefile.orig 2007-09-02 01:57:44.000000000 -0400
+++ git-gui/Makefile
@@ -31,11 +31,11 @@ ifndef INSTALL
INSTALL = install
endif
-INSTALL_D0 = $(INSTALL) -d -m755 # space is required here
+INSTALL_D0 = $(BSD_INSTALL_DATA_DIR) # space is required here
INSTALL_D1 =
-INSTALL_R0 = $(INSTALL) -m644 # space is required here
+INSTALL_R0 = $(BSD_INSTALL_DATA) # space is required here
INSTALL_R1 =
-INSTALL_X0 = $(INSTALL) -m755 # space is required here
+INSTALL_X0 = $(BSD_INSTALL_SCRIPT) # space is required here
INSTALL_X1 =
INSTALL_L0 = rm -f # space is required here
INSTALL_L1 = && ln # space is required here
@@ -50,11 +50,11 @@ ifndef V
QUIET_2DEVNULL = 2>/dev/null
INSTALL_D0 = dir=
- INSTALL_D1 = && echo ' ' DEST $$dir && $(INSTALL) -d -m755 "$$dir"
+ INSTALL_D1 = && echo ' ' DEST $$dir && $(BSD_INSTALL_DATA_DIR) "$$dir"
INSTALL_R0 = src=
- INSTALL_R1 = && echo ' ' INSTALL 644 `basename $$src` && $(INSTALL) -m644 $$src
+ INSTALL_R1 = && echo ' ' INSTALL 644 `basename $$src` && $(BSD_INSTALL_DATA) $$src
INSTALL_X0 = src=
- INSTALL_X1 = && echo ' ' INSTALL 755 `basename $$src` && $(INSTALL) -m755 $$src
+ INSTALL_X1 = && echo ' ' INSTALL 755 `basename $$src` && $(BSD_INSTALL_SCRIPT) $$src
INSTALL_L0 = dst=
INSTALL_L1 = && src=